Upstream information

CVE-2008-1878 at MITRE

Description

Stack-based buffer overflow in the demux_nsf_send_chunk function in src/demuxers/demux_nsf.c in xine-lib 1.1.12 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long NSF title.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 380772 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxine-devel >= 1.1.15-23.3.9
  • libxine1 >= 1.1.15-23.3.9
  • libxine1-32bit >= 1.1.15-23.3.9
  • libxine1-gnome-vfs >= 1.1.15-23.3.9
  • libxine1-pulse >= 1.1.15-23.3.9
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libxine-devel
SUSE LINUX 10.1
  • xine-devel >= 1.1.1-24.39
  • xine-extra >= 1.1.1-24.39
  • xine-lib >= 1.1.1-24.39
  • xine-lib-32bit >= 1.1.1-24.39
  • xine-lib-64bit >= 1.1.1-24.39
  • xine-ui >= 0.99.4-32.35
SUSE Linux Enterprise SDK 10 SP2
  • xine-devel >= 1.1.1-24.40
  • xine-extra >= 1.1.1-24.40
  • xine-lib >= 1.1.1-24.40
  • xine-ui >= 0.99.4-32.36
ZYPP Patch Nr: 5304
SUSE Linux Enterprise SDK 10 SP2
  • xine-devel >= 1.1.1-24.40
  • xine-extra >= 1.1.1-24.40
  • xine-lib >= 1.1.1-24.40
  • xine-lib-x86 >= 1.1.1-24.40
  • xine-ui >= 0.99.4-32.36
ZYPP Patch Nr: 5304
SUSE Linux Enterprise SDK 10 SP2
  • xine-devel >= 1.1.1-24.40
  • xine-extra >= 1.1.1-24.40
  • xine-lib >= 1.1.1-24.40
  • xine-lib-64bit >= 1.1.1-24.40
  • xine-ui >= 0.99.4-32.36
ZYPP Patch Nr: 5304
SUSE Linux Enterprise SDK 10 SP2
  • xine-devel >= 1.1.1-24.40
  • xine-extra >= 1.1.1-24.40
  • xine-lib >= 1.1.1-24.40
  • xine-lib-32bit >= 1.1.1-24.40
  • xine-ui >= 0.99.4-32.36
ZYPP Patch Nr: 5304
Novell Linux Desktop 9 SDK for x86
Novell Linux Desktop 9 SDK for x86_64
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for x86
  • xine-devel >= 0.99.rc3a-106.47
  • xine-extra >= 0.99.rc3a-106.47
  • xine-lib >= 0.99.rc3a-106.47
  • xine-ui >= 0.99.rc3a-106.47
core9.ppc
sle10-sp1-sdk.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
core9.s390x
sles9-nld.x86-64
sle10-sp1-sdk.x86-64
core9.ia64
core9.x86-64
sles9-nld.x86
core9.x86
sles9-nld.x86
sled10.x86
sled10.x86-64
sles9-nld.x86-64
core9.s390
sle10-sp1-sdk.ppc
ZYPP Patch Nr: 5205
Novell Linux Desktop 9 for x86
  • xine-lib >= 0.99.rc3a-106.47
core9.ppc
sle10-sp1-sdk.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
core9.s390x
sles9-nld.x86-64
sle10-sp1-sdk.x86-64
core9.ia64
core9.x86-64
sles9-nld.x86
core9.x86
sles9-nld.x86
sled10.x86
sled10.x86-64
sles9-nld.x86-64
core9.s390
sle10-sp1-sdk.ppc
ZYPP Patch Nr: 5205
Novell Linux Desktop 9 for x86_64
  • xine-lib >= 0.99.rc3a-106.47
  • xine-lib-32bit >= 9-200804211655
core9.ppc
sle10-sp1-sdk.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
core9.s390x
sles9-nld.x86-64
sle10-sp1-sdk.x86-64
core9.ia64
core9.x86-64
sles9-nld.x86
core9.x86
sles9-nld.x86
sled10.x86
sled10.x86-64
sles9-nld.x86-64
core9.s390
sle10-sp1-sdk.ppc
ZYPP Patch Nr: 5205
SLES SDK 9 for IPF
  • xine-devel >= 0.99.rc3a-106.47
  • xine-extra >= 0.99.rc3a-106.47
  • xine-lib >= 0.99.rc3a-106.47
  • xine-lib-x86 >= 9-200804211655
  • xine-ui >= 0.99.rc3a-106.47
core9.ppc
sle10-sp1-sdk.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
core9.s390x
sles9-nld.x86-64
sle10-sp1-sdk.x86-64
core9.ia64
core9.x86-64
sles9-nld.x86
core9.x86
sles9-nld.x86
sled10.x86
sled10.x86-64
sles9-nld.x86-64
core9.s390
sle10-sp1-sdk.ppc
ZYPP Patch Nr: 5205
SLES SDK 9 for IBM iSeries and IBM pSeries
  • xine-devel >= 0.99.rc3a-106.47
  • xine-extra >= 0.99.rc3a-106.47
  • xine-lib >= 0.99.rc3a-106.47
  • xine-lib-64bit >= 9-200804211724
  • xine-ui >= 0.99.rc3a-106.47
core9.ppc
sle10-sp1-sdk.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
core9.s390x
sles9-nld.x86-64
sle10-sp1-sdk.x86-64
core9.ia64
core9.x86-64
sles9-nld.x86
core9.x86
sles9-nld.x86
sled10.x86
sled10.x86-64
sles9-nld.x86-64
core9.s390
sle10-sp1-sdk.ppc
ZYPP Patch Nr: 5205
SLES SDK 9 for IBM zSeries
  • xine-devel >= 0.99.rc3a-106.47
  • xine-extra >= 0.99.rc3a-106.47
  • xine-lib >= 0.99.rc3a-106.47
  • xine-lib-32bit >= 9-200804211647
  • xine-ui >= 0.99.rc3a-106.47
core9.ppc
sle10-sp1-sdk.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
core9.s390x
sles9-nld.x86-64
sle10-sp1-sdk.x86-64
core9.ia64
core9.x86-64
sles9-nld.x86
core9.x86
sles9-nld.x86
sled10.x86
sled10.x86-64
sles9-nld.x86-64
core9.s390
sle10-sp1-sdk.ppc
ZYPP Patch Nr: 5205
SLES SDK 9 for X86-64
  • xine-devel >= 0.99.rc3a-106.47
  • xine-extra >= 0.99.rc3a-106.47
  • xine-lib >= 0.99.rc3a-106.47
  • xine-lib-32bit >= 9-200804211655
  • xine-ui >= 0.99.rc3a-106.47
core9.ppc
sle10-sp1-sdk.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
core9.s390x
sles9-nld.x86-64
sle10-sp1-sdk.x86-64
core9.ia64
core9.x86-64
sles9-nld.x86
core9.x86
sles9-nld.x86
sled10.x86
sled10.x86-64
sles9-nld.x86-64
core9.s390
sle10-sp1-sdk.ppc
ZYPP Patch Nr: 5205