Upstream information

CVE-2008-1801 at MITRE

Description

Integer underflow in the iso_recv_msg function (iso.c) in rdesktop 1.5.0 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a Remote Desktop Protocol (RDP) request with a small length field.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 388168 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise SDK 10 SP2
  • rdesktop >= 1.4.1-17.9
sle10-sp1-sdk.ppc
sles9-nld.x86-64
sles9-nld.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.x86-64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.x86
sle10-sp1-sdk.s390x
sle10-sp2-sdk.ia64
sled10.x86-64
sle10-sp1-sdk.x86
sle10-sp2-sdk.x86-64
sled10-sp2.x86
sle10-sp2-sdk.s390x
sled10.x86
sled10-sp2.x86-64
ZYPP Patch Nr: 5272
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • rdesktop >= 1.3.1-28.2
sle10-sp1-sdk.ppc
sles9-nld.x86-64
sles9-nld.x86
sle10-sp1-sdk.ia64
sle10-sp1-sdk.x86-64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.x86
sle10-sp1-sdk.s390x
sle10-sp2-sdk.ia64
sled10.x86-64
sle10-sp1-sdk.x86
sle10-sp2-sdk.x86-64
sled10-sp2.x86
sle10-sp2-sdk.s390x
sled10.x86
sled10-sp2.x86-64
ZYPP Patch Nr: 5272