Upstream information

CVE-2008-1767 at MITRE

Description

Buffer overflow in pattern.c in libxslt before 1.1.24 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via an XSL style sheet file with a long XSLT "transformation match" condition that triggers a large number of steps.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 391920 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libxslt >= 1.1.24-19.15
  • libxslt-32bit >= 1.1.24-19.15
  • libxslt-x86 >= 1.1.24-19.15
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libxslt
SUSE Linux Enterprise Server 11 SP2
  • libxslt >= 1.1.24-19.15
  • libxslt-32bit >= 1.1.24-19.15
  • libxslt-x86 >= 1.1.24-19.15
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libxslt
SUSE Linux Enterprise Server 11 SP3
  • libxslt >= 1.1.24-19.21.1
  • libxslt-32bit >= 1.1.24-19.21.1
  • libxslt-x86 >= 1.1.24-19.21.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libxslt
SUSE Linux Enterprise Server 11 SP4
  • libxslt >= 1.1.24-19.23.1
  • libxslt-32bit >= 1.1.24-19.23.1
  • libxslt-x86 >= 1.1.24-19.23.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libxslt
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxslt-devel >= 1.1.24-19.23.1
  • libxslt-devel-32bit >= 1.1.24-19.23.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libxslt-devel
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • libxslt >= 1.1.2-58.11
  • libxslt-devel >= 1.1.2-58.11
core9.x86
sles10-sp2.s390x
sles10-sp2.x86-64
core9.ppc
sles10-sp2.ppc
core9.s390
core9.ia64
sles10.ppc
sles9-oes.x86
sles9-nld.x86-64
core9.s390x
sles9-nlpos.x86
sles10.s390x
sled10-sp2.x86
sled10.x86-64
sles10.x86
sled10.x86
sles10.ia64
sles10-sp2.x86
sles10-sp2.ia64
sled10-sp2.x86-64
sles9-nld.x86
sles10.x86-64
core9.x86-64
ZYPP Patch Nr: 5343
Novell Linux Desktop 9 for x86_64
  • libxslt >= 1.1.2-58.11
  • libxslt-32bit >= 9-200805201632
  • libxslt-devel >= 1.1.2-58.11
core9.x86
sles10-sp2.s390x
sles10-sp2.x86-64
core9.ppc
sles10-sp2.ppc
core9.s390
core9.ia64
sles10.ppc
sles9-oes.x86
sles9-nld.x86-64
core9.s390x
sles9-nlpos.x86
sles10.s390x
sled10-sp2.x86
sled10.x86-64
sles10.x86
sled10.x86
sles10.ia64
sles10-sp2.x86
sles10-sp2.ia64
sled10-sp2.x86-64
sles9-nld.x86
sles10.x86-64
core9.x86-64
ZYPP Patch Nr: 5343