Upstream information

CVE-2008-1530 at MITRE

Description

GnuPG (gpg) 1.4.8 and 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via crafted duplicate keys that are imported from key servers, which triggers "memory corruption around deduplication of user IDs."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 374254 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • gpg2 >= 2.0.9-25.25.1
  • gpg2-lang >= 2.0.9-25.25.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA gpg2
SUSE Linux Enterprise Server 11 SP2
  • gpg2 >= 2.0.9-25.33.27.1
  • gpg2-lang >= 2.0.9-25.33.27.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA gpg2
SUSE Linux Enterprise Server 11 SP3
  • gpg2 >= 2.0.9-25.33.31.1
  • gpg2-lang >= 2.0.9-25.33.31.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA gpg2
SUSE Linux Enterprise Server 11 SP4
  • gpg2 >= 2.0.9-25.33.39.1
  • gpg2-lang >= 2.0.9-25.33.39.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA gpg2