Upstream information

CVE-2008-1291 at MITRE

Description

ViewVC before 1.0.5 stores sensitive information under the web root with insufficient access control, which allows remote attackers to read files and list folders under the hidden CVSROOT folder.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 370197 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise SDK 10 SP2
  • cvs2svn >= 1.3.0-30.11
  • subversion >= 1.3.1-1.10
  • subversion-devel >= 1.3.1-1.10
  • subversion-python >= 1.3.1-1.10
  • subversion-server >= 1.3.1-1.10
  • subversion-tools >= 1.3.1-1.10
  • viewcvs >= 1.0.5-0.2
sle10-sp2-sdk.ppc
sle10-sp2-sdk.s390x
sle10-sp1-sdk.ia64
sle10-sp1-sdk.s390x
sle10-sp1-sdk.x86
sled10-sp2.x86-64
sle10-sp2-sdk.x86
sle10-sp1-sdk.ppc
sled10-sp2.x86
sle10-sp2-sdk.ia64
sle10-sp2-sdk.x86-64
sled10.x86
sle10-sp1-sdk.x86-64
sled10.x86-64
ZYPP Patch Nr: 5362
openSUSE 11.0
  • viewvc >= 1.0.5-29.1