Upstream information

CVE-2008-1145 at MITRE

Description

Directory traversal vulnerability in WEBrick in Ruby 1.8 before 1.8.5-p115 and 1.8.6-p114, and 1.9 through 1.9.0-1, when running on systems that support backslash (\) path separators or case-insensitive file names, allows remote attackers to access arbitrary files via (1) "..%5c" (encoded backslash) sequences or (2) filenames that match patterns in the :NondisclosureName option.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 368618 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ruby >= 1.8.7.p72-5.24.2
  • ruby-doc-html >= 1.8.7.p72-5.24.2
  • ruby-tk >= 1.8.7.p72-5.24.2
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ruby
SUSE Linux Enterprise Server 11 SP2
  • ruby >= 1.8.7.p357-0.7.1
  • ruby-doc-html >= 1.8.7.p357-0.7.1
  • ruby-tk >= 1.8.7.p357-0.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ruby
SUSE Linux Enterprise Server 11 SP3
  • ruby >= 1.8.7.p357-0.9.9.1
  • ruby-doc-html >= 1.8.7.p357-0.9.9.1
  • ruby-tk >= 1.8.7.p357-0.9.9.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ruby
SUSE Linux Enterprise Server 11 SP4
  • ruby >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ruby
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ruby-devel >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-doc-ri >= 1.8.7.p357-0.9.17.1
  • ruby-examples >= 1.8.7.p357-0.9.17.1
  • ruby-test-suite >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ruby-devel
SUSE Linux Enterprise SDK 10 SP2
  • ruby >= 1.8.4-17.19
  • ruby-devel >= 1.8.4-17.19
  • ruby-doc-html >= 1.8.4-17.19
  • ruby-doc-ri >= 1.8.4-17.19
  • ruby-examples >= 1.8.4-17.19
  • ruby-test-suite >= 1.8.4-17.19
  • ruby-tk >= 1.8.4-17.19
sled10-sp2.x86
sle10-sp2-sdk.s390x
sle10-sp1-sdk.ia64
sle10-sp1-sdk.x86-64
core9.x86-64
core9.s390
core9.ia64
sled10.x86-64
sle10-sp1-sdk.x86
sle10-sp1-sdk.s390x
sle10-sp1-sdk.ppc
sle-ha.s390x
sles9-nld.x86-64
sle10-sp2-sdk.ppc
sle-ha.x86
sles9-nlpos.x86
core9.x86
sles9-oes.x86
sle10-sp2-sdk.x86
sle10-sp2-sdk.ia64
core9.s390x
sle-ha.ppc
sled10-sp2.x86-64
sle-ha.ia64
sled10.x86
sle-ha.x86-64
sle10-sp2-sdk.x86-64
sles9-nld.x86
core9.ppc
ZYPP Patch Nr: 5484
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • ruby >= 1.8.1-42.24
sled10-sp2.x86
sle10-sp2-sdk.s390x
sle10-sp1-sdk.ia64
sle10-sp1-sdk.x86-64
core9.x86-64
core9.s390
core9.ia64
sled10.x86-64
sle10-sp1-sdk.x86
sle10-sp1-sdk.s390x
sle10-sp1-sdk.ppc
sle-ha.s390x
sles9-nld.x86-64
sle10-sp2-sdk.ppc
sle-ha.x86
sles9-nlpos.x86
core9.x86
sles9-oes.x86
sle10-sp2-sdk.x86
sle10-sp2-sdk.ia64
core9.s390x
sle-ha.ppc
sled10-sp2.x86-64
sle-ha.ia64
sled10.x86
sle-ha.x86-64
sle10-sp2-sdk.x86-64
sles9-nld.x86
core9.ppc
ZYPP Patch Nr: 5484
openSUSE 11.0
  • ruby-debuginfo >= 1.8.6.p114-6.2
  • ruby-debugsource >= 1.8.6.p114-6.2
openSUSE 11.0
  • ruby >= 1.8.6.p114-6.2
  • ruby-devel >= 1.8.6.p114-6.2
  • ruby-doc-html >= 1.8.6.p114-6.2
  • ruby-doc-ri >= 1.8.6.p114-6.2
  • ruby-examples >= 1.8.6.p114-6.2
  • ruby-test-suite >= 1.8.6.p114-6.2
  • ruby-tk >= 1.8.6.p114-6.2