DescriptionCross-site scripting (XSS) vulnerability in the mod_negotiation module in the Apache HTTP Server 2.2.6 and earlier in the 2.2.x series, 2.0.61 and earlier in the 2.0.x series, and 1.3.39 and earlier in the 1.3.x series allows remote authenticated users to inject arbitrary web script or HTML by uploading a file with a name containing XSS sequences and a file extension, which leads to injection within a (1) "406 Not Acceptable" or (2) "300 Multiple Choices" HTTP response when the extension is omitted in a request for the file.
Overall state of this security issue: Resolved
This issue is currently rated as having moderate severity.
|National Vulnerability Database|
Note from the SUSE Security TeamThis issue was not considered a security issue by the Apache Security Team and so is not considered a security issue by us. A statement by the Apache team is published on http://marc.info/?l=apache-httpd-dev&m=120222445311334&w=2.
The Apache developer team has fixed this issue in Apache 2.2.12.SUSE Bugzilla entry: 355540 [RESOLVED / WONTFIX] No SUSE Security Announcements cross referenced.