Upstream information

CVE-2007-6067 at MITRE

Description

Algorithmic complexity vulnerability in the regular expression parser in TCL before 8.4.17, as used in PostgreSQL 8.2 before 8.2.6, 8.1 before 8.1.11, 8.0 before 8.0.15, and 7.4 before 7.4.19, allows remote authenticated users to cause a denial of service (memory consumption) via a crafted "complex" regular expression with doubly-nested states.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:L/Au:S/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entry: 329282 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • postgresql >= 8.3.9-0.1.1
  • postgresql-contrib >= 8.3.9-0.1.1
  • postgresql-docs >= 8.3.9-0.1.1
  • postgresql-libs >= 8.3.9-0.1.1
  • postgresql-libs-32bit >= 8.3.9-0.1.1
  • postgresql-libs-x86 >= 8.3.9-0.1.1
  • postgresql-server >= 8.3.9-0.1.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA postgresql
SUSE Linux Enterprise Server 11 SP2
  • postgresql >= 8.3.14-0.2.1
  • postgresql-contrib >= 8.3.14-0.2.1
  • postgresql-docs >= 8.3.14-0.2.1
  • postgresql-libs >= 8.3.14-0.2.1
  • postgresql-libs-32bit >= 8.3.14-0.2.1
  • postgresql-libs-x86 >= 8.3.14-0.2.1
  • postgresql-server >= 8.3.14-0.2.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA postgresql
SUSE Linux Enterprise Server 11 SP3
  • libecpg6 >= 9.1.9-0.3.1
  • libpq5 >= 9.1.9-0.3.1
  • libpq5-32bit >= 9.1.9-0.3.1
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
  • postgresql91 >= 9.1.9-0.3.1
  • postgresql91-contrib >= 9.1.9-0.3.1
  • postgresql91-docs >= 9.1.9-0.3.1
  • postgresql91-server >= 9.1.9-0.3.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libecpg6
SUSE Linux Enterprise Server 11 SP3 GA postgresql
SUSE Linux Enterprise Server 11 SP4
  • libecpg6 >= 9.4.4-0.6.2
  • libpq5 >= 9.4.4-0.6.2
  • libpq5-32bit >= 9.4.4-0.6.2
  • postgresql >= 8.3.23-0.4.1
  • postgresql-contrib >= 8.3.23-0.4.1
  • postgresql-docs >= 8.3.23-0.4.1
  • postgresql-server >= 8.3.23-0.4.1
  • postgresql94 >= 9.4.4-0.6.2
  • postgresql94-contrib >= 9.4.4-0.6.2
  • postgresql94-docs >= 9.4.4-0.6.2
  • postgresql94-server >= 9.4.4-0.6.2
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libecpg6
SUSE Linux Enterprise Server 11 SP4 GA postgresql
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql-devel >= 8.3.23-0.4.1
  • postgresql94-devel >= 9.4.4-0.6.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql-devel
SUSE Linux Enterprise Software Development Kit 11 SP4 GA postgresql94-devel
SUSE LINUX 10.1
  • postgresql >= 8.1.11-0.2
  • postgresql-contrib >= 8.1.11-0.2
  • postgresql-devel >= 8.1.11-0.2
  • postgresql-docs >= 8.1.11-0.2
  • postgresql-libs >= 8.1.11-0.2
  • postgresql-libs-32bit >= 8.1.11-0.2
  • postgresql-libs-64bit >= 8.1.11-0.2
  • postgresql-pl >= 8.1.11-0.2
  • postgresql-server >= 8.1.11-0.2
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • postgresql >= 7.4.19-0.1
  • postgresql-contrib >= 7.4.19-0.1
  • postgresql-devel >= 7.4.19-0.1
  • postgresql-docs >= 7.4.19-0.1
  • postgresql-libs >= 7.4.19-0.1
  • postgresql-pl >= 7.4.19-0.1
  • postgresql-server >= 7.4.19-0.1
sles9-oes.x86
core9.s390
YOU Patch Nr: 12065
Novell Linux Desktop 9 for x86_64
  • postgresql >= 7.4.19-0.1
  • postgresql-contrib >= 7.4.19-0.1
  • postgresql-devel >= 7.4.19-0.1
  • postgresql-docs >= 7.4.19-0.1
  • postgresql-libs >= 7.4.19-0.1
  • postgresql-libs-32bit >= 9-200801312100
  • postgresql-pl >= 7.4.19-0.1
  • postgresql-server >= 7.4.19-0.1
sles9-oes.x86
core9.s390
YOU Patch Nr: 12065