Upstream information

CVE-2007-5197 at MITRE

Description

Buffer overflow in the Mono.Math.BigInteger class in Mono 1.2.5.1 and earlier allows context-dependent attackers to execute arbitrary code via unspecified vectors related to Reduce in Montgomery-based Pow methods.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 310044 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • bytefx-data-mysql >= 1.1.8.3-6.6
  • ibm-data-db2 >= 1.1.8.3-6.6
  • mono-basic >= 1.1.8.3-6.6
  • mono-core >= 1.1.8.3-6.6
  • mono-core-32bit >= 1.1.8.3-6.6
  • mono-data >= 1.1.8.3-6.6
  • mono-data-oracle >= 1.1.8.3-6.6
  • mono-data-postgresql >= 1.1.8.3-6.6
  • mono-data-sqlite >= 1.1.8.3-6.6
  • mono-data-sybase >= 1.1.8.3-6.6
  • mono-devel >= 1.1.8.3-6.6
  • mono-extras >= 1.1.8.3-6.6
  • mono-ikvm >= 1.1.8.3-6.6
  • mono-locale-extras >= 1.1.8.3-6.6
  • mono-nunit >= 1.1.8.3-6.6
  • mono-web >= 1.1.8.3-6.6
  • mono-winforms >= 1.1.8.3-6.6
SUSE LINUX 10.1
  • bytefx-data-mysql >= 1.1.13.8-2.17
  • ibm-data-db2 >= 1.1.13.8-2.17
  • mono-basic >= 1.1.13.8-2.17
  • mono-core >= 1.1.13.8-2.17
  • mono-core-32bit >= 1.1.13.8-2.17
  • mono-data >= 1.1.13.8-2.17
  • mono-data-firebird >= 1.1.13.8-2.17
  • mono-data-oracle >= 1.1.13.8-2.17
  • mono-data-postgresql >= 1.1.13.8-2.17
  • mono-data-sqlite >= 1.1.13.8-2.17
  • mono-data-sybase >= 1.1.13.8-2.17
  • mono-devel >= 1.1.13.8-2.17
  • mono-extras >= 1.1.13.8-2.17
  • mono-jscript >= 1.1.13.8-2.17
  • mono-locale-extras >= 1.1.13.8-2.17
  • mono-nunit >= 1.1.13.8-2.17
  • mono-web >= 1.1.13.8-2.17
  • mono-winforms >= 1.1.13.8-2.17
Open Enterprise Server
  • mono-core >= 1.1.7.7-0.14
  • mono-data >= 1.1.7.7-0.14
  • mono-web >= 1.1.7.7-0.14
sles10-sdk.x86-64
sles10.x86
sles10-sdk.ia64
sles9-oes.x86
sled10.x86
sles10.x86-64
sles10.ia64
sles10-sdk.x86
sles10-sdk.s390x
sles10-sdk.ppc
sles10.s390x
sles10.ppc
ZYPP Patch Nr: 4453