Upstream information

CVE-2007-5162 at MITRE

Description

The connect method in lib/net/http.rb in the (1) Net::HTTP and (2) Net::HTTPS libraries in Ruby 1.8.5 and 1.8.6 does not verify that the commonName (CN) field in a server certificate matches the domain name in an HTTPS request, which makes it easier for remote attackers to intercept SSL transmissions via a man-in-the-middle attack or spoofed web site.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 329706 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ruby >= 1.8.7.p72-5.24.2
  • ruby-doc-html >= 1.8.7.p72-5.24.2
  • ruby-tk >= 1.8.7.p72-5.24.2
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ruby
SUSE Linux Enterprise Server 11 SP2
  • ruby >= 1.8.7.p357-0.7.1
  • ruby-doc-html >= 1.8.7.p357-0.7.1
  • ruby-tk >= 1.8.7.p357-0.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ruby
SUSE Linux Enterprise Server 11 SP3
  • ruby >= 1.8.7.p357-0.9.9.1
  • ruby-doc-html >= 1.8.7.p357-0.9.9.1
  • ruby-tk >= 1.8.7.p357-0.9.9.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ruby
SUSE Linux Enterprise Server 11 SP4
  • ruby >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ruby
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ruby-devel >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-doc-ri >= 1.8.7.p357-0.9.17.1
  • ruby-examples >= 1.8.7.p357-0.9.17.1
  • ruby-test-suite >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ruby-devel
SUSE LINUX 10.1
  • ruby >= 1.8.4-17.16
  • ruby-devel >= 1.8.4-17.16
  • ruby-doc-html >= 1.8.4-17.16
  • ruby-doc-ri >= 1.8.4-17.16
  • ruby-examples >= 1.8.4-17.16
  • ruby-test-suite >= 1.8.4-17.16
  • ruby-tk >= 1.8.4-17.16