Upstream information

CVE-2007-4988 at MITRE

Description

Sign extension error in the ReadDIBImage function in ImageMagick before 6.3.5-9 allows context-dependent attackers to execute arbitrary code via a crafted width value in an image file, which triggers an integer overflow and a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 327021 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libMagickCore1 >= 6.4.3.6-7.20.1
  • libMagickCore1-32bit >= 6.4.3.6-7.20.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libMagickCore1-32bit
SUSE Linux Enterprise Server 11 SP2
  • libMagickCore1 >= 6.4.3.6-7.22.1
  • libMagickCore1-32bit >= 6.4.3.6-7.22.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libMagickCore1-32bit
SUSE Linux Enterprise Server 11 SP3
  • libMagickCore1 >= 6.4.3.6-7.26.1
  • libMagickCore1-32bit >= 6.4.3.6-7.26.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libMagickCore1-32bit
SUSE Linux Enterprise Server 11 SP4
  • libMagickCore1 >= 6.4.3.6-7.30.1
  • libMagickCore1-32bit >= 6.4.3.6-7.30.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libMagickCore1-32bit
SUSE Linux Enterprise Software Development Kit 11 SP4
  • GraphicsMagick >= 1.2.5-4.33.1
  • ImageMagick >= 6.4.3.6-7.30.1
  • ImageMagick-devel >= 6.4.3.6-7.30.1
  • libGraphicsMagick2 >= 1.2.5-4.33.1
  • libMagick++-devel >= 6.4.3.6-7.30.1
  • libMagick++1 >= 6.4.3.6-7.30.1
  • libMagickWand1 >= 6.4.3.6-7.30.1
  • libMagickWand1-32bit >= 6.4.3.6-7.30.1
  • perl-GraphicsMagick >= 1.2.5-4.33.1
  • perl-PerlMagick >= 6.4.3.6-7.30.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA GraphicsMagick
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ImageMagick
SuSE Linux Desktop 1.0
  • ImageMagick >= 5.4.7-302
Builds
ZYPP Patch Nr: 4541
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
  • ImageMagick >= 5.4.7-302
  • perl-PerlMagick >= 5.4.7-302
Builds
ZYPP Patch Nr: 4541
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • ImageMagick >= 5.5.7-225.37
  • ImageMagick-devel >= 5.5.7-225.37
Builds
ZYPP Patch Nr: 4541
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • ImageMagick >= 5.5.7-225.37
  • ImageMagick-Magick++ >= 5.5.7-225.37
  • ImageMagick-devel >= 5.5.7-225.37
  • perl-PerlMagick >= 5.5.7-225.37
Builds
ZYPP Patch Nr: 4541
SUSE LINUX 10.0
  • ImageMagick >= 6.2.3-4.17
  • ImageMagick-Magick++ >= 6.2.3-4.17
  • ImageMagick-Magick++-devel >= 6.2.3-4.17
  • ImageMagick-devel >= 6.2.3-4.17
  • perl-PerlMagick >= 6.2.3-4.17
SUSE LINUX 10.1
  • ImageMagick >= 6.2.5-16.26
  • ImageMagick-Magick++ >= 6.2.5-16.26
  • ImageMagick-Magick++-devel >= 6.2.5-16.26
  • ImageMagick-devel >= 6.2.5-16.26
  • perl-PerlMagick >= 6.2.5-16.26