Upstream information

CVE-2007-4974 at MITRE

Description

Heap-based buffer overflow in the flac_buffer_copy function in libsndfile 1.0.17 and earlier might allow remote attackers to execute arbitrary code via a FLAC file with crafted PCM data containing a block with a size that exceeds the previous block size.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 326070 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libsndfile >= 1.0.20-2.1.46
  • libsndfile-32bit >= 1.0.20-2.1.46
  • libsndfile-x86 >= 1.0.20-2.1.46
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libsndfile
SUSE Linux Enterprise Server 11 SP2
  • libsndfile >= 1.0.20-2.4.1
  • libsndfile-32bit >= 1.0.20-2.4.1
  • libsndfile-x86 >= 1.0.20-2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libsndfile
SUSE Linux Enterprise Server 11 SP3
  • libsndfile >= 1.0.20-2.4.1
  • libsndfile-32bit >= 1.0.20-2.4.1
  • libsndfile-x86 >= 1.0.20-2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libsndfile
SUSE Linux Enterprise Server 11 SP4
  • libsndfile >= 1.0.20-2.6.5
  • libsndfile-32bit >= 1.0.20-2.6.5
  • libsndfile-x86 >= 1.0.20-2.6.5
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libsndfile
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libsndfile-devel >= 1.0.20-2.6.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libsndfile-devel
SUSE LINUX 10.1
  • libsndfile >= 1.0.12-13.7
  • libsndfile-32bit >= 1.0.12-13.7
  • libsndfile-64bit >= 1.0.12-13.7
  • libsndfile-devel >= 1.0.12-13.7
  • libsndfile-octave >= 1.0.12-13.7
  • libsndfile-progs >= 1.0.12-13.7