Upstream information

CVE-2007-4569 at MITRE

Description

backend/session.c in KDM in KDE 3.3.0 through 3.5.7, when autologin is configured and "shutdown with password" is enabled, allows remote attackers to bypass the password requirement and login to arbitrary accounts via unspecified vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:L/AC:L/Au:S/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication Single
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 307372 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • kdebase3-runtime >= 3.5.10-20.31
  • kdebase3-runtime-32bit >= 3.5.10-20.31
  • kdebase3-runtime-x86 >= 3.5.10-20.31
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA kdebase3-runtime
SUSE Linux Enterprise Server 11 SP2
  • kdebase3-runtime >= 3.5.10-20.31
  • kdebase3-runtime-32bit >= 3.5.10-20.31
  • kdebase3-runtime-x86 >= 3.5.10-20.31
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA kdebase3-runtime
SUSE Linux Enterprise Server 11 SP3
  • kdebase3-runtime >= 3.5.10-20.31
  • kdebase3-runtime-32bit >= 3.5.10-20.31
  • kdebase3-runtime-x86 >= 3.5.10-20.31
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA kdebase3-runtime
SUSE Linux Enterprise Server 11 SP4
  • kdebase3-runtime >= 3.5.10-20.31
  • kdebase3-runtime-32bit >= 3.5.10-20.31
  • kdebase3-runtime-x86 >= 3.5.10-20.31
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA kdebase3-runtime
SUSE Linux Enterprise Software Development Kit 11 SP4
  • fileshareset >= 2.0-20.31
  • kdebase3 >= 3.5.10-20.31
  • kdebase3-32bit >= 3.5.10-20.31
  • kdebase3-devel >= 3.5.10-20.31
  • kdebase3-runtime-32bit >= 3.5.10-20.31
  • misc-console-font >= 3.5.10-20.31
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA fileshareset
SUSE LINUX 10.0
  • kdebase3 >= 3.4.2-27.8
  • kdebase3-32bit >= 3.4.2-27.8
  • kdebase3-64bit >= 3.4.2-27.8
  • kdebase3-devel >= 3.4.2-27.8
  • kdebase3-extra >= 3.4.2-27.8
  • kdebase3-kdm >= 3.4.2-27.8
  • kdebase3-ksysguardd >= 3.4.2-27.8
  • kdebase3-nsplugin >= 3.4.2-27.8
  • kdebase3-nsplugin64 >= 3.4.2-27.8
  • kdebase3-samba >= 3.4.2-27.8
  • kdebase3-session >= 3.4.2-27.8
  • kdelibs3 >= 3.4.2-24.8
  • kdelibs3-32bit >= 3.4.2-24.8
  • kdelibs3-64bit >= 3.4.2-24.8
  • kdelibs3-arts >= 3.4.2-24.8
  • kdelibs3-devel >= 3.4.2-24.8
  • kdelibs3-doc >= 3.4.2-24.8
SUSE LINUX 10.1
  • fileshareset >= 2.0-84.57
  • kdebase3 >= 3.5.1-69.58
  • kdebase3-32bit >= 3.5.1-69.58
  • kdebase3-64bit >= 3.5.1-69.58
  • kdebase3-devel >= 3.5.1-69.58
  • kdebase3-extra >= 3.5.1-69.58
  • kdebase3-kdm >= 3.5.1-69.58
  • kdebase3-ksysguardd >= 3.5.1-69.58
  • kdebase3-nsplugin >= 3.5.1-69.58
  • kdebase3-nsplugin64 >= 3.5.1-69.58
  • kdebase3-samba >= 3.5.1-69.58
  • kdebase3-session >= 3.5.1-69.58
  • kdelibs3 >= 3.5.1-49.39
  • kdelibs3-32bit >= 3.5.1-49.39
  • kdelibs3-64bit >= 3.5.1-49.39
  • kdelibs3-arts >= 3.5.1-49.39
  • kdelibs3-arts-32bit >= 3.5.1-49.39
  • kdelibs3-arts-64bit >= 3.5.1-49.39
  • kdelibs3-devel >= 3.5.1-49.39
  • kdelibs3-doc >= 3.5.1-49.39