Upstream information

CVE-2007-3770 at MITRE

Description

The terminal_helper_execute function in terminal/terminal.c in Xfce Terminal 0.2.6 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in a crafted link, as demonstrated using the "Open Link" functionality.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:M/Au:N/C:C/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 292988 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.