Upstream information

CVE-2007-3645 at MITRE

Description

archive_read_support_format_tar.c in libarchive before 2.2.4 allows user-assisted remote attackers to cause a denial of service (crash) via (1) an end-of-file condition within a tar header that follows a pax extension header or (2) a malformed pax extension header in an (a) PAX or a (b) TAR archive, which results in a NULL pointer dereference, a different issue than CVE-2007-3644.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 291358 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libarchive2 >= 2.5.5-5.19
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libarchive2
SUSE Linux Enterprise Server 11 SP2
  • libarchive2 >= 2.5.5-5.19
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libarchive2
SUSE Linux Enterprise Server 11 SP3
  • libarchive2 >= 2.5.5-5.19
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libarchive2
SUSE Linux Enterprise Server 11 SP4
  • libarchive2 >= 2.5.5-5.19
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libarchive2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libarchive-devel >= 2.5.5-5.19
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libarchive-devel