Upstream information

CVE-2007-2873 at MITRE

Description

SpamAssassin 3.1.x, 3.2.0, and 3.2.1 before 20070611, when running as root in unusual configurations using vpopmail or virtual users, allows local users to cause a denial of service (corrupt arbitrary files) via a symlink attack on a file that is used by spamd.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.9
Vector AV:L/AC:M/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 284488 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • perl-spamassassin >= 3.2.5-26.22.18
  • spamassassin >= 3.2.5-26.22.18
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA perl-spamassassin
SUSE Linux Enterprise Server 11 SP2
  • perl-spamassassin >= 3.3.1-10.8.3
  • spamassassin >= 3.3.1-10.8.3
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA perl-spamassassin
SUSE Linux Enterprise Server 11 SP3
  • perl-spamassassin >= 3.3.1-10.8.3
  • spamassassin >= 3.3.1-10.8.3
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA perl-spamassassin
SUSE Linux Enterprise Server 11 SP4
  • perl-spamassassin >= 3.3.1-10.8.3
  • spamassassin >= 3.3.1-10.8.3
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA perl-spamassassin