Upstream information

CVE-2007-2721 at MITRE

Description

The jpc_qcx_getcompparms function in jpc/jpc_cs.c for the JasPer JPEG-2000 library (libjasper) before 1.900 allows remote user-assisted attackers to cause a denial of service (crash) and possibly corrupt the heap via malformed image files, as originally demonstrated using imagemagick convert.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 258253 [RESOLVED / FIXED], 339731 [RESOLVED / FIXED], 340138 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • jasper >= 1.701.0-4.3
  • libjasper >= 1.701.0-4.3
  • libjasper-32bit >= 1.701.0-4.3
  • libjasper-64bit >= 1.701.0-4.3
SUSE LINUX 10.1
  • jasper >= 1.701.0-16.6
  • libjasper >= 1.701.0-16.6
  • libjasper-32bit >= 1.701.0-16.6
  • libjasper-64bit >= 1.701.0-16.6
SUSE LINUX 9.3
  • jasper >= 1.701.0-3.3
  • libjasper >= 1.701.0-3.3
  • libjasper-32bit >= 9.3-0.1
SUSE LINUX 10.0
  • libnetpbm >= 1.0.0-636.5
  • libnetpbm-32bit >= 1.0.0-636.5
  • libnetpbm-64bit >= 1.0.0-636.5
  • netpbm >= 10.26.12-5.7
SUSE LINUX 10.1
  • libnetpbm >= 1.0.0-657.6
  • libnetpbm-32bit >= 1.0.0-657.6
  • libnetpbm-64bit >= 1.0.0-657.6
  • netpbm >= 10.26.22-14.6