Upstream information

CVE-2007-2519 at MITRE

Description

Directory traversal vulnerability in the installer in PEAR 1.0 through 1.5.3 allows user-assisted remote attackers to overwrite arbitrary files via a .. (dot dot) sequence in the (1) install-as attribute in the file element in package.xml 1.0 or the (2) as attribute in the install element in package.xml 2.0. NOTE: it could be argued that this does not cross privilege boundaries in typical installations, since the code being installed could perform the same actions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 274162 [RESOLVED / FIXED], 735613 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • apache2-mod_php5 >= 5.2.14-0.42.1
  • php5 >= 5.2.14-0.42.1
  • php5-bcmath >= 5.2.14-0.42.1
  • php5-bz2 >= 5.2.14-0.42.1
  • php5-calendar >= 5.2.14-0.42.1
  • php5-ctype >= 5.2.14-0.42.1
  • php5-curl >= 5.2.14-0.42.1
  • php5-dba >= 5.2.14-0.42.1
  • php5-dbase >= 5.2.14-0.42.1
  • php5-devel >= 5.2.14-0.42.1
  • php5-dom >= 5.2.14-0.42.1
  • php5-exif >= 5.2.14-0.42.1
  • php5-fastcgi >= 5.2.14-0.42.1
  • php5-ftp >= 5.2.14-0.42.1
  • php5-gd >= 5.2.14-0.42.1
  • php5-gettext >= 5.2.14-0.42.1
  • php5-gmp >= 5.2.14-0.42.1
  • php5-hash >= 5.2.14-0.42.1
  • php5-iconv >= 5.2.14-0.42.1
  • php5-imap >= 5.2.14-0.42.1
  • php5-json >= 5.2.14-0.42.1
  • php5-ldap >= 5.2.14-0.42.1
  • php5-mbstring >= 5.2.14-0.42.1
  • php5-mcrypt >= 5.2.14-0.42.1
  • php5-mhash >= 5.2.14-0.42.1
  • php5-mysql >= 5.2.14-0.42.1
  • php5-ncurses >= 5.2.14-0.42.1
  • php5-odbc >= 5.2.14-0.42.1
  • php5-openssl >= 5.2.14-0.42.1
  • php5-pcntl >= 5.2.14-0.42.1
  • php5-pdo >= 5.2.14-0.42.1
  • php5-pear >= 5.2.14-0.42.1
  • php5-pgsql >= 5.2.14-0.42.1
  • php5-posix >= 5.2.14-0.42.1
  • php5-pspell >= 5.2.14-0.42.1
  • php5-shmop >= 5.2.14-0.42.1
  • php5-snmp >= 5.2.14-0.42.1
  • php5-soap >= 5.2.14-0.42.1
  • php5-sockets >= 5.2.14-0.42.1
  • php5-sqlite >= 5.2.14-0.42.1
  • php5-suhosin >= 5.2.14-0.42.1
  • php5-sysvmsg >= 5.2.14-0.42.1
  • php5-sysvsem >= 5.2.14-0.42.1
  • php5-sysvshm >= 5.2.14-0.42.1
  • php5-tokenizer >= 5.2.14-0.42.1
  • php5-wddx >= 5.2.14-0.42.1
  • php5-xmlreader >= 5.2.14-0.42.1
  • php5-xmlrpc >= 5.2.14-0.42.1
  • php5-xsl >= 5.2.14-0.42.1
  • php5-zlib >= 5.2.14-0.42.1
Builds
ZYPP Patch Nr: 8658


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP1 php5 Released
SUSE Linux Enterprise SDK 11 SP2 php5 Released
SUSE Linux Enterprise Server 10 SP3 php5 Released
SUSE Linux Enterprise Server 10 SP4 php5 Released
SUSE Linux Enterprise Server 10 SP4 LTSS php5 Released
SUSE Linux Enterprise Server 11 SP1 php5 Released
SUSE Linux Enterprise Server 11 SP1 LTSS php5 Released
SUSE Linux Enterprise Server 11 SP2 php5 Released
SUSE Linux Enterprise Server 11 SP2 LTSS php5 Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 php5 Released
SUSE Linux Enterprise Server for VMWare 11 SP2 php5 Released