Upstream information

CVE-2007-1862 at MITRE

Description

The recall_headers function in mod_mem_cache in Apache 2.2.4 does not properly copy all levels of header data, which can cause Apache to return HTTP headers containing previously used data, which could be used by remote attackers to obtain potentially sensitive information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 280414 [RESOLVED / DUPLICATE], 308637 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • apache2 >= 2.2.10-2.24.5
  • apache2-doc >= 2.2.10-2.24.5
  • apache2-example-pages >= 2.2.10-2.24.5
  • apache2-prefork >= 2.2.10-2.24.5
  • apache2-utils >= 2.2.10-2.24.5
  • apache2-worker >= 2.2.10-2.24.5
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA apache2
SUSE Linux Enterprise Server 11 SP2
  • apache2 >= 2.2.12-1.28.1
  • apache2-doc >= 2.2.12-1.28.1
  • apache2-example-pages >= 2.2.12-1.28.1
  • apache2-prefork >= 2.2.12-1.28.1
  • apache2-utils >= 2.2.12-1.28.1
  • apache2-worker >= 2.2.12-1.28.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA apache2
SUSE Linux Enterprise Server 11 SP3
  • apache2 >= 2.2.12-1.38.2
  • apache2-doc >= 2.2.12-1.38.2
  • apache2-example-pages >= 2.2.12-1.38.2
  • apache2-prefork >= 2.2.12-1.38.2
  • apache2-utils >= 2.2.12-1.38.2
  • apache2-worker >= 2.2.12-1.38.2
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA apache2
SUSE Linux Enterprise Server 11 SP4
  • apache2 >= 2.2.12-1.51.52.1
  • apache2-doc >= 2.2.12-1.51.52.1
  • apache2-example-pages >= 2.2.12-1.51.52.1
  • apache2-prefork >= 2.2.12-1.51.52.1
  • apache2-utils >= 2.2.12-1.51.52.1
  • apache2-worker >= 2.2.12-1.51.52.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA apache2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • apache2 >= 2.2.12-1.51.52.1
  • apache2-devel >= 2.2.12-1.51.52.1
  • apache2-doc >= 2.2.12-1.51.52.1
  • apache2-example-pages >= 2.2.12-1.51.52.1
  • apache2-prefork >= 2.2.12-1.51.52.1
  • apache2-utils >= 2.2.12-1.51.52.1
  • apache2-worker >= 2.2.12-1.51.52.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA apache2
SUSE LINUX 10.0
  • apache2 >= 2.0.54-10.11
  • apache2-devel >= 2.0.54-10.11
  • apache2-doc >= 2.0.54-10.11
  • apache2-example-pages >= 2.0.54-10.11
  • apache2-prefork >= 2.0.54-10.11
  • apache2-worker >= 2.0.54-10.11
  • libapr0 >= 2.0.54-10.11
SUSE LINUX 10.1
  • apache2 >= 2.2.3-16.15
  • apache2-devel >= 2.2.3-16.15
  • apache2-doc >= 2.2.3-16.15
  • apache2-example-pages >= 2.2.3-16.15
  • apache2-prefork >= 2.2.3-16.15
  • apache2-worker >= 2.2.3-16.15