Upstream information

CVE-2007-1841 at MITRE

Description

The isakmp_info_recv function in src/racoon/isakmp_inf.c in racoon in Ipsec-tools before 0.6.7 allows remote attackers to cause a denial of service (tunnel crash) via crafted (1) DELETE (ISAKMP_NPTYPE_D) and (2) NOTIFY (ISAKMP_NPTYPE_N) messages.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 260791 [RESOLVED / FIXED], 334907 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ipsec-tools >= 0.7.3-1.1.93
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ipsec-tools
SUSE Linux Enterprise Server 11 SP2
  • ipsec-tools >= 0.7.3-1.1.93
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ipsec-tools
SUSE Linux Enterprise Server 11 SP3
  • ipsec-tools >= 0.7.3-1.1.93
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ipsec-tools
SUSE Linux Enterprise Server 11 SP4
  • ipsec-tools >= 0.7.3-1.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ipsec-tools
SUSE Linux Enterprise Software Development Kit 11 SP4
  • novell-ipsec-tools >= 0.7.1-2.29.1
  • novell-ipsec-tools-devel >= 0.7.1-2.29.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA novell-ipsec-tools
SUSE LINUX 10.0
  • ipsec-tools >= 0.6-4.5
SUSE LINUX 10.1
  • ipsec-tools >= 0.6.5-10.6
SUSE LINUX 9.3
  • ipsec-tools >= 0.5-5.5
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • ipsec-tools >= 0.3.3-1.12
core9.s390
sles9-oes.x86
sles10.s390x
sles10.x86
ZYPP Patch Nr: 3099