Upstream information

CVE-2007-0905 at MITRE

Description

PHP before 5.2.1 allows attackers to bypass safe_mode and open_basedir restrictions via unspecified vectors in the session extension. NOTE: it is possible that this issue is a duplicate of CVE-2006-6383.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 244034 [RESOLVED / FIXED], 258746 [RESOLVED / FIXED], 307272 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • apache2 >= 2.2.3-16.9
  • apache2-devel >= 2.2.3-16.9
  • apache2-doc >= 2.2.3-16.9
  • apache2-example-pages >= 2.2.3-16.9
  • apache2-mod_php5 >= 5.1.2-29.35
  • apache2-prefork >= 2.2.3-16.9
  • apache2-worker >= 2.2.3-16.9
  • php5 >= 5.1.2-29.35
  • php5-bcmath >= 5.1.2-29.35
  • php5-bz2 >= 5.1.2-29.35
  • php5-calendar >= 5.1.2-29.35
  • php5-ctype >= 5.1.2-29.35
  • php5-curl >= 5.1.2-29.35
  • php5-dba >= 5.1.2-29.35
  • php5-dbase >= 5.1.2-29.35
  • php5-devel >= 5.1.2-29.35
  • php5-dom >= 5.1.2-29.35
  • php5-exif >= 5.1.2-29.35
  • php5-fastcgi >= 5.1.2-29.35
  • php5-filepro >= 5.1.2-29.35
  • php5-ftp >= 5.1.2-29.35
  • php5-gd >= 5.1.2-29.35
  • php5-gettext >= 5.1.2-29.35
  • php5-gmp >= 5.1.2-29.35
  • php5-iconv >= 5.1.2-29.35
  • php5-imap >= 5.1.2-29.35
  • php5-ldap >= 5.1.2-29.35
  • php5-mbstring >= 5.1.2-29.35
  • php5-mcrypt >= 5.1.2-29.35
  • php5-mhash >= 5.1.2-29.35
  • php5-mysql >= 5.1.2-29.35
  • php5-mysqli >= 5.1.2-29.35
  • php5-ncurses >= 5.1.2-29.35
  • php5-odbc >= 5.1.2-29.35
  • php5-openssl >= 5.1.2-29.35
  • php5-pcntl >= 5.1.2-29.35
  • php5-pdo >= 5.1.2-29.35
  • php5-pear >= 5.1.2-29.35
  • php5-pgsql >= 5.1.2-29.35
  • php5-posix >= 5.1.2-29.35
  • php5-pspell >= 5.1.2-29.35
  • php5-shmop >= 5.1.2-29.35
  • php5-snmp >= 5.1.2-29.35
  • php5-soap >= 5.1.2-29.35
  • php5-sockets >= 5.1.2-29.35
  • php5-sqlite >= 5.1.2-29.35
  • php5-sysvmsg >= 5.1.2-29.35
  • php5-sysvsem >= 5.1.2-29.35
  • php5-sysvshm >= 5.1.2-29.35
  • php5-tokenizer >= 5.1.2-29.35
  • php5-wddx >= 5.1.2-29.35
  • php5-xmlreader >= 5.1.2-29.35
  • php5-xmlrpc >= 5.1.2-29.35
  • php5-xsl >= 5.1.2-29.35
  • php5-zlib >= 5.1.2-29.35
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2769
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • php5-suhosin >= 5.1.2-29.35
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2875