Upstream information

CVE-2007-0537 at MITRE

Description

The KDE HTML library (kdelibs), as used by Konqueror 3.5.5, does not properly parse HTML comments, which allows remote attackers to conduct cross-site scripting (XSS) attacks and bypass some XSS protection schemes by embedding certain HTML tags within a comment in a title tag, a related issue to CVE-2007-0478.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 238377 [RESOLVED / FIXED], 240583 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • kdelibs3 >= 3.4.2-24.6
  • kdelibs3-32bit >= 3.4.2-24.6
  • kdelibs3-64bit >= 3.4.2-24.6
  • kdelibs3-devel >= 3.4.2-24.6
SUSE LINUX 10.1
  • kdelibs3 >= 3.5.1-49.18.3
  • kdelibs3-32bit >= 3.5.1-49.18.3
  • kdelibs3-64bit >= 3.5.1-49.18.3
  • kdelibs3-devel >= 3.5.1-49.18.3
SUSE LINUX 9.3
  • kdelibs3 >= 3.4.0-20.14
  • kdelibs3-32bit >= 9.3-7.6
  • kdelibs3-devel >= 3.4.0-20.14
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • kdelibs3 >= 3.2.1-44.69
  • kdelibs3-devel >= 3.2.1-44.69
sles10.s390x
core9.s390
sles9-oes.x86
sled10.x86
ZYPP Patch Nr: 3053
Novell Linux Desktop 9 for x86_64
  • kdelibs3 >= 3.2.1-44.69
  • kdelibs3-32bit >= 9-200704031835
  • kdelibs3-devel >= 3.2.1-44.69
sles10.s390x
core9.s390
sles9-oes.x86
sled10.x86
ZYPP Patch Nr: 3053