Upstream information

CVE-2006-7217 at MITRE

Description

Apache Derby before 10.2.1.6 does not determine schema privilege requirements during the DropSchemaNode bind phase, which allows remote authenticated users to execute arbitrary drop schema statements in SQL authorization mode.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 291035 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • derby >= 10.3.1.4-1.16
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA derby
SUSE LINUX 10.0
  • derby >= 10.3.1.4-0.1
SUSE LINUX 10.1
  • derby >= 10.3.1.4-0.2
openSUSE Tumbleweed
  • derby >= 10.11.1.1-3.2
  • derby-javadoc >= 10.11.1.1-3.2
Patchnames:
openSUSE Tumbleweed GA derby