Upstream information

CVE-2006-7216 at MITRE

Description

Apache Derby before 10.2.1.6 does not determine privilege requirements for lock table statements at compilation time, and consequently does not enforce privilege requirements at execution time, which allows remote authenticated users to lock arbitrary tables.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 291035 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • derby >= 10.3.1.4-1.16
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA derby
openSUSE Tumbleweed
  • derby >= 10.11.1.1-3.2
  • derby-javadoc >= 10.11.1.1-3.2
Patchnames:
openSUSE Tumbleweed GA derby