Upstream information

CVE-2006-6303 at MITRE

Description

The read_multipart function in cgi.rb in Ruby before 1.8.5-p2 does not properly detect boundaries in MIME multipart content, which allows remote attackers to cause a denial of service (infinite loop) via crafted HTTP requests, a different issue than CVE-2006-5467.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 225983 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ruby >= 1.8.7.p72-5.24.2
  • ruby-doc-html >= 1.8.7.p72-5.24.2
  • ruby-tk >= 1.8.7.p72-5.24.2
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ruby
SUSE Linux Enterprise Server 11 SP2
  • ruby >= 1.8.7.p357-0.7.1
  • ruby-doc-html >= 1.8.7.p357-0.7.1
  • ruby-tk >= 1.8.7.p357-0.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ruby
SUSE Linux Enterprise Server 11 SP3
  • ruby >= 1.8.7.p357-0.9.9.1
  • ruby-doc-html >= 1.8.7.p357-0.9.9.1
  • ruby-tk >= 1.8.7.p357-0.9.9.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ruby
SUSE Linux Enterprise Server 11 SP4
  • ruby >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ruby
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ruby-devel >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-doc-ri >= 1.8.7.p357-0.9.17.1
  • ruby-examples >= 1.8.7.p357-0.9.17.1
  • ruby-test-suite >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ruby-devel
SUSE LINUX 10.0
  • ruby >= 1.8.2-11.11
SUSE LINUX 10.1
  • ruby >= 1.8.4-17.12
SUSE LINUX 9.3
  • ruby >= 1.8.1-51.13
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • ruby >= 1.6.7-139
slrs8.x86
sles9-oes.x86
ul1.s390
core9.s390
ZYPP Patch Nr: 2654
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • ruby >= 1.8.1-42.22
slrs8.x86
sles9-oes.x86
ul1.s390
core9.s390
ZYPP Patch Nr: 2654