Upstream information

CVE-2006-6142 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.0 through 1.4.9 allow remote attackers to inject arbitrary web script or HTML via the (1) mailto parameter in (a) webmail.php, the (2) session and (3) delete_draft parameters in (b) compose.php, and (4) unspecified vectors involving "a shortcoming in the magicHTML filter."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 227849 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • squirrelmail >= 1.4.5-5.9
SUSE LINUX 10.1
  • squirrelmail >= 1.4.5-18.4
SUSE LINUX 9.3
  • squirrelmail >= 1.4.2-64.15
SUSE LINUX 10.0
  • squirrelmail >= 1.4.5-5.12
SUSE LINUX 10.1
  • squirrelmail >= 1.4.5-18.7
SUSE LINUX 9.3
  • squirrelmail >= 1.4.2-64.17
SUSE LINUX 10.0
  • squirrelmail >= 1.4.5-5.9
SUSE LINUX 10.1
  • squirrelmail >= 1.4.5-18.4
SUSE LINUX 9.3
  • squirrelmail >= 1.4.2-64.15