Upstream information

CVE-2006-5170 at MITRE

Description

pam_ldap in nss_ldap on Red Hat Enterprise Linux 4, Fedora Core 3 and earlier, and possibly other distributions does not return an error condition when an LDAP directory server responds with a PasswordPolicyResponse control response, which causes the pam_authenticate function to return a success code even if authentication has failed, as originally reported for xscreensaver.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 210158 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • pam_ldap >= 184-147.20
  • pam_ldap-32bit >= 184-147.20
  • pam_ldap-x86 >= 184-147.20
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA pam_ldap
SUSE Linux Enterprise Server 11 SP2
  • pam_ldap >= 184-147.20
  • pam_ldap-32bit >= 184-147.20
  • pam_ldap-x86 >= 184-147.20
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA pam_ldap
SUSE Linux Enterprise Server 11 SP3
  • pam_ldap >= 184-147.20
  • pam_ldap-32bit >= 184-147.20
  • pam_ldap-x86 >= 184-147.20
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA pam_ldap
SUSE Linux Enterprise Server 11 SP4
  • pam_ldap >= 184-147.20
  • pam_ldap-32bit >= 184-147.20
  • pam_ldap-x86 >= 184-147.20
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA pam_ldap
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • pam_ldap >= 169-28.7
core9.s390
sles9-oes.x86
sled10.x86
sles10.s390x
ZYPP Patch Nr: 2196
Novell Linux Desktop 9 for x86_64
  • pam_ldap >= 169-28.7
  • pam_ldap-32bit >= 9-200610241503
core9.s390
sles9-oes.x86
sled10.x86
sles10.s390x
ZYPP Patch Nr: 2196
SUSE LINUX 10.0
  • pam_ldap >= 178-3.2
  • pam_ldap-32bit >= 178-3.2
  • pam_ldap-64bit >= 178-3.2
SUSE LINUX 10.1
  • pam_ldap >= 180-13.5
  • pam_ldap-32bit >= 180-13.5
  • pam_ldap-64bit >= 180-13.5
SUSE LINUX 9.2
  • pam_ldap >= 169-29.4
  • pam_ldap-32bit >= 9.2-200610231734
SUSE LINUX 9.3
  • pam_ldap >= 176-3.4
  • pam_ldap-32bit >= 9.3-7.2
SUSE Linux Enterprise Desktop 10 SP1 for x86
SUSE Linux Enterprise Server 10 SP1 for x86
  • nss_ldap >= 246-14.13
  • pam_ldap >= 180-13.12
sles10.s390x
sled10.x86
ZYPP Patch Nr: 2760
SUSE Linux Enterprise Desktop 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
  • nss_ldap >= 246-14.13
  • nss_ldap-32bit >= 246-14.13
  • pam_ldap >= 180-13.12
  • pam_ldap-32bit >= 180-13.12
sles10.s390x
sled10.x86
ZYPP Patch Nr: 2760
SUSE Linux Enterprise Server 10 SP1 for IPF
  • nss_ldap >= 246-14.13
  • nss_ldap-x86 >= 246-14.13
  • pam_ldap >= 180-13.12
  • pam_ldap-x86 >= 180-13.12
sles10.s390x
sled10.x86
ZYPP Patch Nr: 2760
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
  • nss_ldap >= 246-14.13
  • nss_ldap-64bit >= 246-14.13
  • pam_ldap >= 180-13.12
  • pam_ldap-64bit >= 180-13.12
sles10.s390x
sled10.x86
ZYPP Patch Nr: 2760