Upstream information

CVE-2006-4227 at MITRE

Description

MySQL before 5.0.25 and 5.1 before 5.1.12 evaluates arguments of suid routines in the security context of the routine's definer instead of the routine's caller, which allows remote authenticated users to gain privileges through a routine that has been made available using GRANT EXECUTE.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 201711 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libmysqlclient15 >= 5.0.67-13.20.1
  • libmysqlclient15-32bit >= 5.0.67-13.20.1
  • libmysqlclient15-x86 >= 5.0.67-13.20.1
  • libmysqlclient_r15 >= 5.0.67-13.20.1
  • mysql >= 5.0.67-13.20.1
  • mysql-Max >= 5.0.67-13.20.1
  • mysql-client >= 5.0.67-13.20.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libmysqlclient15-32bit
SUSE Linux Enterprise Server 11 SP2
  • libmysqlclient15 >= 5.0.94-0.2.4.1
  • libmysqlclient15-32bit >= 5.0.94-0.2.4.1
  • libmysqlclient15-x86 >= 5.0.94-0.2.4.1
  • libmysqlclient_r15 >= 5.0.94-0.2.4.1
  • mysql >= 5.0.94-0.2.4.1
  • mysql-Max >= 5.0.94-0.2.4.1
  • mysql-client >= 5.0.94-0.2.4.1
  • mysql-tools >= 5.0.94-0.2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libmysqlclient15-32bit
SUSE Linux Enterprise Server 11 SP3
  • libmysqlclient15 >= 5.0.96-0.6.1
  • libmysqlclient15-32bit >= 5.0.96-0.6.1
  • libmysqlclient15-x86 >= 5.0.96-0.6.1
  • libmysqlclient_r15 >= 5.0.96-0.6.1
  • mysql >= 5.5.31-0.7.10
  • mysql-client >= 5.5.31-0.7.10
  • mysql-tools >= 5.5.31-0.7.10
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libmysqlclient15-32bit
SUSE Linux Enterprise Server 11 SP4
  • libmysql55client18 >= 5.5.43-0.7.3
  • libmysql55client18-32bit >= 5.5.43-0.7.3
  • libmysql55client18-x86 >= 5.5.43-0.7.3
  • libmysql55client_r18 >= 5.5.43-0.7.3
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient15 >= 5.0.96-0.6.20
  • libmysqlclient15-32bit >= 5.0.96-0.6.20
  • libmysqlclient15-x86 >= 5.0.96-0.6.20
  • libmysqlclient_r15 >= 5.0.96-0.6.20
  • mysql >= 5.5.43-0.7.3
  • mysql-client >= 5.5.43-0.7.3
  • mysql-tools >= 5.5.43-0.7.3
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libmysql55client18-32bit
SUSE Linux Enterprise Server 11 SP4 GA libmysqlclient15-32bit
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • libmysqlclient-devel >= 5.0.96-0.6.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.20
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.20
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysql55client_r18-32bit
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmysqlclient-devel
SUSE LINUX 10.1
  • mysql >= 5.0.18-20.8
  • mysql-Max >= 5.0.18-20.8