Upstream information

CVE-2006-3404 at MITRE

Description

Buffer overflow in the xcf_load_vector function in app/xcf/xcf-load.c for gimp before 2.2.12 allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via an XCF file with a large num_axes value in the VECTORS property.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 190901 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • gimp >= 2.6.2-3.34.45.1
  • gimp-devel >= 2.6.2-3.34.45.1
  • gimp-lang >= 2.6.2-3.34.45.1
  • gimp-plugins-python >= 2.6.2-3.34.45.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA gimp
SUSE LINUX 10.0
  • gimp-unstable >= 2.3.3-5.2
SUSE LINUX 10.1
  • gimp-unstable >= 2.3.7-17.2
SUSE LINUX 10.0
  • gimp >= 2.2.8-6.2
SUSE LINUX 10.1
  • gimp >= 2.2.10-22.5
SUSE LINUX 9.2
  • gimp >= 2.0.4-3.2
SUSE LINUX 9.3
  • gimp >= 2.2.4-3.2
SUSE Linux Enterprise Desktop 10 SP1 for x86
  • cairo >= 1.0.2-27.16
  • cairo-devel >= 1.0.2-27.16
  • cairo-doc >= 1.0.2-27.16
  • control-center2 >= 2.12.3-0.21
  • control-center2-devel >= 2.12.3-0.21
  • eel >= 2.12.2-18.14
  • eel-devel >= 2.12.2-18.14
  • evolution-data-server >= 1.6.0-43.53
  • evolution-data-server-devel >= 1.6.0-43.53
  • ghex >= 2.8.1-27.14
  • gimp >= 2.2.10-22.20
  • gimp-devel >= 2.2.10-22.20
  • gnome-applets >= 2.12.2-51.14
  • gnome-applets-devel >= 2.12.2-51.14
  • gnome-cups-manager >= 0.32cvs20060120-33.23
  • gnome-cups-manager-devel >= 0.32cvs20060120-33.23
  • gnome-desktop >= 2.12.2-25.16
  • gnome-desktop-devel >= 2.12.2-25.16
  • gnome-keyring >= 0.4.6-18.16
  • gnome-keyring-devel >= 0.4.6-18.16
  • gnome-main-menu >= 0.9.8-0.15
  • gnome-main-menu-devel >= 0.9.8-0.15
  • gnome-menus >= 2.16.1-38.11
  • gnome-menus-devel >= 2.16.1-38.11
  • gnome-panel-nld >= 2.12.3-0.35
  • gnome-panel-nld-devel >= 2.12.3-0.35
  • gnome-panel-nld-doc >= 2.12.3-0.35
  • gnome-vfs2 >= 2.12.2-58.28
  • gnome-vfs2-devel >= 2.12.2-58.28
  • gnome-vfs2-doc >= 2.12.2-58.28
  • gstreamer010 >= 0.10.4-11.17
  • gstreamer010-devel >= 0.10.4-11.17
  • gstreamer010-doc >= 0.10.4-11.17
  • gtk2 >= 2.8.11-0.15
  • gtk2-devel >= 2.8.11-0.15
  • gtk2-doc >= 2.8.11-0.15
  • gtkhtml2 >= 3.10.0-15.15
  • gtkhtml2-devel >= 3.10.0-15.15
  • intltool >= 0.35.2-4.10
  • libgnomedb >= 1.3.91-23.14
  • libgnomedb-devel >= 1.3.91-23.14
  • libgnomesu >= 1.0.0-32.24
  • libgnomesu-devel >= 1.0.0-32.24
  • libgnomeui >= 2.12.1-0.13
  • libgnomeui-devel >= 2.12.1-0.13
  • libgnomeui-doc >= 2.12.1-0.13
  • libgsf >= 1.13.99-13.13
  • libgsf-devel >= 1.13.99-13.13
  • libgsf-doc >= 1.13.99-13.13
  • libgsf-gnome >= 1.13.99-13.13
  • libsoup >= 2.2.90-18.19
  • libsoup-devel >= 2.2.90-18.19
  • mozilla-nspr >= 4.6.4-0.7
  • mozilla-nspr-devel >= 4.6.4-0.7
  • nautilus >= 2.12.2-64.33
  • nautilus-devel >= 2.12.2-64.33
  • vte >= 0.11.17-0.11
  • vte-devel >= 0.11.17-0.11
sles10.ppc
sles10.s390x
sles10.x86
sles10.ia64
sles10.x86-64
ZYPP Patch Nr: 3051
SUSE Linux Enterprise Desktop 10 SP1 for AMD64 and Intel EM64T
  • cairo >= 1.0.2-27.16
  • cairo-32bit >= 1.0.2-27.16
  • cairo-devel >= 1.0.2-27.16
  • cairo-doc >= 1.0.2-27.16
  • control-center2 >= 2.12.3-0.21
  • control-center2-devel >= 2.12.3-0.21
  • eel >= 2.12.2-18.14
  • eel-32bit >= 2.12.2-18.14
  • eel-devel >= 2.12.2-18.14
  • evolution-data-server >= 1.6.0-43.53
  • evolution-data-server-32bit >= 1.6.0-43.53
  • evolution-data-server-devel >= 1.6.0-43.53
  • ghex >= 2.8.1-27.14
  • gimp >= 2.2.10-22.20
  • gimp-devel >= 2.2.10-22.20
  • gnome-applets >= 2.12.2-51.14
  • gnome-applets-devel >= 2.12.2-51.14
  • gnome-cups-manager >= 0.32cvs20060120-33.23
  • gnome-cups-manager-devel >= 0.32cvs20060120-33.23
  • gnome-desktop >= 2.12.2-25.16
  • gnome-desktop-32bit >= 2.12.2-25.16
  • gnome-desktop-devel >= 2.12.2-25.16
  • gnome-keyring >= 0.4.6-18.16
  • gnome-keyring-32bit >= 0.4.6-18.16
  • gnome-keyring-devel >= 0.4.6-18.16
  • gnome-main-menu >= 0.9.8-0.15
  • gnome-main-menu-devel >= 0.9.8-0.15
  • gnome-menus >= 2.16.1-38.11
  • gnome-menus-32bit >= 2.16.1-38.11
  • gnome-menus-devel >= 2.16.1-38.11
  • gnome-panel-nld >= 2.12.3-0.35
  • gnome-panel-nld-32bit >= 2.12.3-0.35
  • gnome-panel-nld-devel >= 2.12.3-0.35
  • gnome-panel-nld-doc >= 2.12.3-0.35
  • gnome-vfs2 >= 2.12.2-58.28
  • gnome-vfs2-32bit >= 2.12.2-58.28
  • gnome-vfs2-devel >= 2.12.2-58.28
  • gnome-vfs2-doc >= 2.12.2-58.28
  • gstreamer010 >= 0.10.4-11.17
  • gstreamer010-32bit >= 0.10.4-11.17
  • gstreamer010-devel >= 0.10.4-11.17
  • gstreamer010-doc >= 0.10.4-11.17
  • gtk2 >= 2.8.11-0.15
  • gtk2-32bit >= 2.8.11-0.15
  • gtk2-devel >= 2.8.11-0.15
  • gtk2-doc >= 2.8.11-0.15
  • gtkhtml2 >= 3.10.0-15.15
  • gtkhtml2-devel >= 3.10.0-15.15
  • intltool >= 0.35.2-4.10
  • libgnomedb >= 1.3.91-23.14
  • libgnomedb-devel >= 1.3.91-23.14
  • libgnomesu >= 1.0.0-32.24
  • libgnomesu-devel >= 1.0.0-32.24
  • libgnomeui >= 2.12.1-0.13
  • libgnomeui-32bit >= 2.12.1-0.13
  • libgnomeui-devel >= 2.12.1-0.13
  • libgnomeui-doc >= 2.12.1-0.13
  • libgsf >= 1.13.99-13.13
  • libgsf-32bit >= 1.13.99-13.13
  • libgsf-devel >= 1.13.99-13.13
  • libgsf-doc >= 1.13.99-13.13
  • libgsf-gnome >= 1.13.99-13.13
  • libsoup >= 2.2.90-18.19
  • libsoup-32bit >= 2.2.90-18.19
  • libsoup-devel >= 2.2.90-18.19
  • libsoup-devel-32bit >= 2.2.90-18.19
  • mozilla-nspr >= 4.6.4-0.7
  • mozilla-nspr-32bit >= 4.6.4-0.7
  • mozilla-nspr-devel >= 4.6.4-0.7
  • nautilus >= 2.12.2-64.33
  • nautilus-32bit >= 2.12.2-64.33
  • nautilus-devel >= 2.12.2-64.33
  • vte >= 0.11.17-0.11
  • vte-devel >= 0.11.17-0.11
sles10.ppc
sles10.s390x
sles10.x86
sles10.ia64
sles10.x86-64
ZYPP Patch Nr: 3051
SUSE Linux Enterprise Server 10 SP1 for x86
  • cairo >= 1.0.2-27.16
  • cairo-devel >= 1.0.2-27.16
  • cairo-doc >= 1.0.2-27.16
  • control-center2 >= 2.12.3-0.21
  • control-center2-devel >= 2.12.3-0.21
  • eel >= 2.12.2-18.14
  • eel-devel >= 2.12.2-18.14
  • evolution-data-server >= 1.6.0-43.53
  • evolution-data-server-devel >= 1.6.0-43.53
  • gnome-applets >= 2.12.2-51.14
  • gnome-applets-devel >= 2.12.2-51.14
  • gnome-cups-manager >= 0.32cvs20060120-33.23
  • gnome-cups-manager-devel >= 0.32cvs20060120-33.23
  • gnome-desktop >= 2.12.2-25.16
  • gnome-desktop-devel >= 2.12.2-25.16
  • gnome-keyring >= 0.4.6-18.16
  • gnome-keyring-devel >= 0.4.6-18.16
  • gnome-main-menu >= 0.9.8-0.15
  • gnome-menus >= 2.16.1-38.11
  • gnome-menus-devel >= 2.16.1-38.11
  • gnome-panel-nld >= 2.12.3-0.35
  • gnome-panel-nld-doc >= 2.12.3-0.35
  • gnome-vfs2 >= 2.12.2-58.28
  • gnome-vfs2-devel >= 2.12.2-58.28
  • gnome-vfs2-doc >= 2.12.2-58.28
  • gstreamer010 >= 0.10.4-11.17
  • gstreamer010-doc >= 0.10.4-11.17
  • gtk2 >= 2.8.11-0.15
  • gtk2-devel >= 2.8.11-0.15
  • gtk2-doc >= 2.8.11-0.15
  • gtkhtml2 >= 3.10.0-15.15
  • libgnomedb >= 1.3.91-23.14
  • libgnomedb-devel >= 1.3.91-23.14
  • libgnomesu >= 1.0.0-32.24
  • libgnomesu-devel >= 1.0.0-32.24
  • libgnomeui >= 2.12.1-0.13
  • libgnomeui-devel >= 2.12.1-0.13
  • libgnomeui-doc >= 2.12.1-0.13
  • libgsf >= 1.13.99-13.13
  • libgsf-devel >= 1.13.99-13.13
  • libgsf-doc >= 1.13.99-13.13
  • libgsf-gnome >= 1.13.99-13.13
  • libsoup >= 2.2.90-18.19
  • libsoup-devel >= 2.2.90-18.19
  • mozilla-nspr >= 4.6.4-0.7
  • mozilla-nspr-devel >= 4.6.4-0.7
  • nautilus >= 2.12.2-64.33
  • nautilus-devel >= 2.12.2-64.33
  • vte >= 0.11.17-0.11
  • vte-devel >= 0.11.17-0.11
sles10.ppc
sles10.s390x
sles10.x86
sles10.ia64
sles10.x86-64
ZYPP Patch Nr: 3051
SUSE Linux Enterprise Server 10 SP1 for IPF
  • cairo >= 1.0.2-27.16
  • cairo-devel >= 1.0.2-27.16
  • cairo-doc >= 1.0.2-27.16
  • cairo-x86 >= 1.0.2-27.16
  • control-center2 >= 2.12.3-0.21
  • control-center2-devel >= 2.12.3-0.21
  • eel >= 2.12.2-18.14
  • eel-devel >= 2.12.2-18.14
  • eel-x86 >= 2.12.2-18.14
  • evolution-data-server >= 1.6.0-43.53
  • evolution-data-server-devel >= 1.6.0-43.53
  • evolution-data-server-x86 >= 1.6.0-43.53
  • gnome-applets >= 2.12.2-51.14
  • gnome-applets-devel >= 2.12.2-51.14
  • gnome-cups-manager >= 0.32cvs20060120-33.23
  • gnome-cups-manager-devel >= 0.32cvs20060120-33.23
  • gnome-desktop >= 2.12.2-25.16
  • gnome-desktop-devel >= 2.12.2-25.16
  • gnome-desktop-x86 >= 2.12.2-25.16
  • gnome-keyring >= 0.4.6-18.16
  • gnome-keyring-devel >= 0.4.6-18.16
  • gnome-keyring-x86 >= 0.4.6-18.16
  • gnome-main-menu >= 0.9.8-0.15
  • gnome-menus >= 2.16.1-38.11
  • gnome-menus-devel >= 2.16.1-38.11
  • gnome-menus-x86 >= 2.16.1-38.11
  • gnome-panel-nld >= 2.12.3-0.35
  • gnome-panel-nld-doc >= 2.12.3-0.35
  • gnome-panel-nld-x86 >= 2.12.3-0.35
  • gnome-vfs2 >= 2.12.2-58.28
  • gnome-vfs2-devel >= 2.12.2-58.28
  • gnome-vfs2-doc >= 2.12.2-58.28
  • gnome-vfs2-x86 >= 2.12.2-58.28
  • gstreamer010 >= 0.10.4-11.17
  • gstreamer010-doc >= 0.10.4-11.17
  • gstreamer010-x86 >= 0.10.4-11.17
  • gtk2 >= 2.8.11-0.15
  • gtk2-devel >= 2.8.11-0.15
  • gtk2-doc >= 2.8.11-0.15
  • gtk2-x86 >= 2.8.11-0.15
  • gtkhtml2 >= 3.10.0-15.15
  • libgnomedb >= 1.3.91-23.14
  • libgnomedb-devel >= 1.3.91-23.14
  • libgnomesu >= 1.0.0-32.24
  • libgnomesu-devel >= 1.0.0-32.24
  • libgnomeui >= 2.12.1-0.13
  • libgnomeui-devel >= 2.12.1-0.13
  • libgnomeui-doc >= 2.12.1-0.13
  • libgnomeui-x86 >= 2.12.1-0.13
  • libgsf >= 1.13.99-13.13
  • libgsf-devel >= 1.13.99-13.13
  • libgsf-doc >= 1.13.99-13.13
  • libgsf-gnome >= 1.13.99-13.13
  • libgsf-x86 >= 1.13.99-13.13
  • libsoup >= 2.2.90-18.19
  • libsoup-devel >= 2.2.90-18.19
  • libsoup-x86 >= 2.2.90-18.19
  • mozilla-nspr >= 4.6.4-0.7
  • mozilla-nspr-devel >= 4.6.4-0.7
  • mozilla-nspr-x86 >= 4.6.4-0.7
  • nautilus >= 2.12.2-64.33
  • nautilus-devel >= 2.12.2-64.33
  • nautilus-x86 >= 2.12.2-64.33
  • vte >= 0.11.17-0.11
  • vte-devel >= 0.11.17-0.11
sles10.ppc
sles10.s390x
sles10.x86
sles10.ia64
sles10.x86-64
ZYPP Patch Nr: 3051
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
  • cairo >= 1.0.2-27.16
  • cairo-64bit >= 1.0.2-27.16
  • cairo-devel >= 1.0.2-27.16
  • cairo-doc >= 1.0.2-27.16
  • control-center2 >= 2.12.3-0.21
  • control-center2-devel >= 2.12.3-0.21
  • eel >= 2.12.2-18.14
  • eel-64bit >= 2.12.2-18.14
  • eel-devel >= 2.12.2-18.14
  • evolution-data-server >= 1.6.0-43.53
  • evolution-data-server-64bit >= 1.6.0-43.53
  • evolution-data-server-devel >= 1.6.0-43.53
  • gnome-applets >= 2.12.2-51.14
  • gnome-applets-devel >= 2.12.2-51.14
  • gnome-cups-manager >= 0.32cvs20060120-33.23
  • gnome-cups-manager-devel >= 0.32cvs20060120-33.23
  • gnome-desktop >= 2.12.2-25.16
  • gnome-desktop-64bit >= 2.12.2-25.16
  • gnome-desktop-devel >= 2.12.2-25.16
  • gnome-keyring >= 0.4.6-18.16
  • gnome-keyring-64bit >= 0.4.6-18.16
  • gnome-keyring-devel >= 0.4.6-18.16
  • gnome-main-menu >= 0.9.8-0.15
  • gnome-menus >= 2.16.1-38.11
  • gnome-menus-64bit >= 2.16.1-38.11
  • gnome-menus-devel >= 2.16.1-38.11
  • gnome-panel-nld >= 2.12.3-0.35
  • gnome-panel-nld-64bit >= 2.12.3-0.35
  • gnome-panel-nld-doc >= 2.12.3-0.35
  • gnome-vfs2 >= 2.12.2-58.28
  • gnome-vfs2-64bit >= 2.12.2-58.28
  • gnome-vfs2-devel >= 2.12.2-58.28
  • gnome-vfs2-doc >= 2.12.2-58.28
  • gstreamer010 >= 0.10.4-11.17
  • gstreamer010-64bit >= 0.10.4-11.17
  • gstreamer010-doc >= 0.10.4-11.17
  • gtk2 >= 2.8.11-0.15
  • gtk2-64bit >= 2.8.11-0.15
  • gtk2-devel >= 2.8.11-0.15
  • gtk2-devel-64bit >= 2.8.11-0.15
  • gtk2-doc >= 2.8.11-0.15
  • gtkhtml2 >= 3.10.0-15.15
  • libgnomedb >= 1.3.91-23.14
  • libgnomedb-devel >= 1.3.91-23.14
  • libgnomesu >= 1.0.0-32.24
  • libgnomesu-devel >= 1.0.0-32.24
  • libgnomeui >= 2.12.1-0.13
  • libgnomeui-64bit >= 2.12.1-0.13
  • libgnomeui-devel >= 2.12.1-0.13
  • libgnomeui-doc >= 2.12.1-0.13
  • libgsf >= 1.13.99-13.13
  • libgsf-64bit >= 1.13.99-13.13
  • libgsf-devel >= 1.13.99-13.13
  • libgsf-doc >= 1.13.99-13.13
  • libgsf-gnome >= 1.13.99-13.13
  • libsoup >= 2.2.90-18.19
  • libsoup-64bit >= 2.2.90-18.19
  • libsoup-devel >= 2.2.90-18.19
  • libsoup-devel-64bit >= 2.2.90-18.19
  • mozilla-nspr >= 4.6.4-0.7
  • mozilla-nspr-64bit >= 4.6.4-0.7
  • mozilla-nspr-devel >= 4.6.4-0.7
  • nautilus >= 2.12.2-64.33
  • nautilus-64bit >= 2.12.2-64.33
  • nautilus-devel >= 2.12.2-64.33
  • vte >= 0.11.17-0.11
  • vte-devel >= 0.11.17-0.11
sles10.ppc
sles10.s390x
sles10.x86
sles10.ia64
sles10.x86-64
ZYPP Patch Nr: 3051
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
  • cairo >= 1.0.2-27.16
  • cairo-32bit >= 1.0.2-27.16
  • cairo-devel >= 1.0.2-27.16
  • cairo-doc >= 1.0.2-27.16
  • control-center2 >= 2.12.3-0.21
  • control-center2-devel >= 2.12.3-0.21
  • eel >= 2.12.2-18.14
  • eel-32bit >= 2.12.2-18.14
  • eel-devel >= 2.12.2-18.14
  • evolution-data-server >= 1.6.0-43.53
  • evolution-data-server-32bit >= 1.6.0-43.53
  • evolution-data-server-devel >= 1.6.0-43.53
  • gnome-applets >= 2.12.2-51.14
  • gnome-applets-devel >= 2.12.2-51.14
  • gnome-cups-manager >= 0.32cvs20060120-33.23
  • gnome-cups-manager-devel >= 0.32cvs20060120-33.23
  • gnome-desktop >= 2.12.2-25.16
  • gnome-desktop-32bit >= 2.12.2-25.16
  • gnome-desktop-devel >= 2.12.2-25.16
  • gnome-keyring >= 0.4.6-18.16
  • gnome-keyring-32bit >= 0.4.6-18.16
  • gnome-keyring-devel >= 0.4.6-18.16
  • gnome-main-menu >= 0.9.8-0.15
  • gnome-menus >= 2.16.1-38.11
  • gnome-menus-32bit >= 2.16.1-38.11
  • gnome-menus-devel >= 2.16.1-38.11
  • gnome-panel-nld >= 2.12.3-0.35
  • gnome-panel-nld-32bit >= 2.12.3-0.35
  • gnome-panel-nld-doc >= 2.12.3-0.35
  • gnome-vfs2 >= 2.12.2-58.28
  • gnome-vfs2-32bit >= 2.12.2-58.28
  • gnome-vfs2-devel >= 2.12.2-58.28
  • gnome-vfs2-doc >= 2.12.2-58.28
  • gstreamer010 >= 0.10.4-11.17
  • gstreamer010-32bit >= 0.10.4-11.17
  • gstreamer010-doc >= 0.10.4-11.17
  • gtk2 >= 2.8.11-0.15
  • gtk2-32bit >= 2.8.11-0.15
  • gtk2-devel >= 2.8.11-0.15
  • gtk2-doc >= 2.8.11-0.15
  • gtkhtml2 >= 3.10.0-15.15
  • libgnomedb >= 1.3.91-23.14
  • libgnomedb-devel >= 1.3.91-23.14
  • libgnomesu >= 1.0.0-32.24
  • libgnomesu-devel >= 1.0.0-32.24
  • libgnomeui >= 2.12.1-0.13
  • libgnomeui-32bit >= 2.12.1-0.13
  • libgnomeui-devel >= 2.12.1-0.13
  • libgnomeui-doc >= 2.12.1-0.13
  • libgsf >= 1.13.99-13.13
  • libgsf-32bit >= 1.13.99-13.13
  • libgsf-devel >= 1.13.99-13.13
  • libgsf-doc >= 1.13.99-13.13
  • libgsf-gnome >= 1.13.99-13.13
  • libsoup >= 2.2.90-18.19
  • libsoup-32bit >= 2.2.90-18.19
  • libsoup-devel >= 2.2.90-18.19
  • libsoup-devel-32bit >= 2.2.90-18.19
  • mozilla-nspr >= 4.6.4-0.7
  • mozilla-nspr-32bit >= 4.6.4-0.7
  • mozilla-nspr-devel >= 4.6.4-0.7
  • nautilus >= 2.12.2-64.33
  • nautilus-32bit >= 2.12.2-64.33
  • nautilus-devel >= 2.12.2-64.33
  • vte >= 0.11.17-0.11
  • vte-devel >= 0.11.17-0.11
sles10.ppc
sles10.s390x
sles10.x86
sles10.ia64
sles10.x86-64
ZYPP Patch Nr: 3051
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • gimp >= 2.0.2-1.5
core9.x86
core9.ia64
core9.s390
core9.x86-64
core9.ppc
ZYPP Patch Nr: 1920
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • gimp >= 2.0.0-16.8
core9.x86
core9.ia64
core9.s390
core9.x86-64
core9.ppc
ZYPP Patch Nr: 1920