Upstream information

CVE-2006-0996 at MITRE

Description

Cross-site scripting (XSS) vulnerability in phpinfo (info.c) in PHP 5.1.2 and 4.4.2 allows remote attackers to inject arbitrary web script or HTML via long array variables, including (1) a large number of dimensions or (2) long values, which prevents HTML tags from being removed.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 164804 [RESOLVED / FIXED], 164845 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-503
  • mod_php4-core >= 4.2.2-503
  • mod_php4-devel >= 4.2.2-503
  • mod_php4-servlet >= 4.2.2-503
Builds
YOU Patch Nr: 10959
SUSE LINUX 10.0
  • apache2-mod_php5 >= 5.0.4-9.10
  • php5 >= 5.0.4-9.10
  • php5-exif >= 5.0.4-9.10
  • php5-fastcgi >= 5.0.4-9.10
  • php5-mbstring >= 5.0.4-9.10
  • php5-pear >= 5.0.4-9.10
  • php5-snmp >= 5.0.4-9.10
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.20
  • mod_php4-servlet >= 4.3.10-14.20
  • php4 >= 4.3.10-14.20
  • php4-32bit >= 9.3-7.9
  • php4-devel >= 4.3.10-14.20
  • php4-exif >= 4.3.10-14.20
  • php4-fastcgi >= 4.3.10-14.20
  • php4-mbstring >= 4.3.10-14.20
  • php4-pear >= 4.3.10-14.20
  • php4-session >= 4.3.10-14.20
  • php4-sysvshm >= 4.3.10-14.20
SUSE LINUX 10.0
  • apache2-mod_php4 >= 4.4.0-6.10
  • php4 >= 4.4.0-6.10
  • php4-32bit >= 4.4.0-6.10
  • php4-64bit >= 4.4.0-6.10
  • php4-exif >= 4.4.0-6.10
  • php4-fastcgi >= 4.4.0-6.10
  • php4-mbstring >= 4.4.0-6.10
  • php4-servlet >= 4.4.0-6.10
  • php4-unixODBC >= 4.4.0-6.10
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.20
  • php5 >= 5.0.3-14.20
  • php5-devel >= 5.0.3-14.20
  • php5-exif >= 5.0.3-14.20
  • php5-fastcgi >= 5.0.3-14.20
  • php5-mbstring >= 5.0.3-14.20
  • php5-pear >= 5.0.3-14.20
  • php5-sysvmsg >= 5.0.3-14.20
  • php5-sysvshm >= 5.0.3-14.20
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • php5-suhosin >= 5.1.2-29.35
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2875
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.53
  • apache2-mod_php4 >= 4.3.4-43.53
  • mod_php4-core >= 4.3.4-43.53
  • mod_php4-servlet >= 4.3.4-43.53
  • php4 >= 4.3.4-43.53
  • php4-devel >= 4.3.4-43.53
  • php4-exif >= 4.3.4-43.53
  • php4-fastcgi >= 4.3.4-43.53
  • php4-imap >= 4.3.4-43.53
  • php4-mbstring >= 4.3.4-43.53
  • php4-mysql >= 4.3.4-43.53
  • php4-pear >= 4.3.4-43.53
  • php4-recode >= 4.3.4-43.53
  • php4-servlet >= 4.3.4-43.53
  • php4-session >= 4.3.4-43.53
  • php4-sysvshm >= 4.3.4-43.53
Builds
YOU Patch Nr: 10960