Upstream information

CVE-2006-0645 at MITRE

Description

Tiny ASN.1 Library (libtasn1) before 0.2.18, as used by (1) GnuTLS 1.2.x before 1.2.10 and 1.3.x before 1.3.4, and (2) GNU Shishi, allows attackers to crash the DER decoder and possibly execute arbitrary code via "out-of-bounds access" caused by invalid input, as demonstrated by the ProtoVer SSL test suite.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 149897 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • gnutls >= 1.0.8-26.7
  • gnutls-devel >= 1.0.8-26.7
core9.ia64
core9.s390
core9.x86-64
sles9-nlpos.x86
core9.ppc
YOU Patch Nr: 10886
Novell Linux Desktop 9 for x86_64
  • gnutls >= 1.0.8-26.7
  • gnutls-32bit >= 9-200602210534
  • gnutls-devel >= 1.0.8-26.7
  • gnutls-devel-32bit >= 9-200602210534
core9.ia64
core9.s390
core9.x86-64
sles9-nlpos.x86
core9.ppc
YOU Patch Nr: 10886
SUSE LINUX 10.0
  • gnutls >= 1.2.5-3.2
  • gnutls-32bit >= 1.2.5-3.2
  • gnutls-64bit >= 1.2.5-3.2
  • gnutls-devel >= 1.2.5-3.2
  • gnutls-devel-32bit >= 1.2.5-3.2
  • gnutls-devel-64bit >= 1.2.5-3.2
SUSE LINUX 9.1 for IA32
  • gnutls >= 1.0.8-26.7
  • gnutls-devel >= 1.0.8-26.7
SUSE LINUX 9.2
  • gnutls >= 1.0.13-5.4
  • gnutls-32bit >= 9.2-200602210430
  • gnutls-devel >= 1.0.13-5.4
  • gnutls-devel-32bit >= 9.2-200602210430
SUSE LINUX 9.3
  • gnutls >= 1.2.0-3.4
  • gnutls-32bit >= 9.3-7.2
  • gnutls-devel >= 1.2.0-3.4
  • gnutls-devel-32bit >= 9.3-7.2