Upstream information

CVE-2006-0208 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in PHP 4.4.1 and 5.1.1, when display_errors and html_errors are on, allow remote attackers to inject arbitrary web script or HTML via inputs to PHP applications that are not filtered when they are included in the resulting error message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 143696 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • apache2-mod_php4 >= 4.4.0-6.8
  • php4 >= 4.4.0-6.8
  • php4-32bit >= 4.4.0-6.8
  • php4-64bit >= 4.4.0-6.8
  • php4-exif >= 4.4.0-6.8
  • php4-fastcgi >= 4.4.0-6.8
  • php4-mbstring >= 4.4.0-6.8
  • php4-servlet >= 4.4.0-6.8
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.50
  • apache2-mod_php4 >= 4.3.4-43.50
  • mod_php4-core >= 4.3.4-43.50
  • mod_php4-servlet >= 4.3.4-43.50
  • php4 >= 4.3.4-43.50
  • php4-devel >= 4.3.4-43.50
  • php4-exif >= 4.3.4-43.50
  • php4-fastcgi >= 4.3.4-43.50
  • php4-imap >= 4.3.4-43.50
  • php4-mbstring >= 4.3.4-43.50
  • php4-mysql >= 4.3.4-43.50
  • php4-pear >= 4.3.4-43.50
  • php4-recode >= 4.3.4-43.50
  • php4-servlet >= 4.3.4-43.50
  • php4-session >= 4.3.4-43.50
  • php4-sysvshm >= 4.3.4-43.50
core9.x86-64
core9.ppc
core9.x86
core9.s390
YOU Patch Nr: 10875
SUSE LINUX 10.0
  • apache2-mod_php5 >= 5.0.4-9.8
  • php5 >= 5.0.4-9.8
  • php5-exif >= 5.0.4-9.8
  • php5-fastcgi >= 5.0.4-9.8
  • php5-mbstring >= 5.0.4-9.8
  • php5-pear >= 5.0.4-9.8
  • php5-snmp >= 5.0.4-9.8
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.18
  • php5 >= 5.0.3-14.18
  • php5-devel >= 5.0.3-14.18
  • php5-exif >= 5.0.3-14.18
  • php5-fastcgi >= 5.0.3-14.18
  • php5-mbstring >= 5.0.3-14.18
  • php5-pear >= 5.0.3-14.18
  • php5-sysvmsg >= 5.0.3-14.18
  • php5-sysvshm >= 5.0.3-14.18
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-500
  • mod_php4-core >= 4.2.2-500
  • mod_php4-devel >= 4.2.2-500
  • mod_php4-servlet >= 4.2.2-500
ul1.ia64
slox5.x86
ul1.ppc
ul1.x86-64
ul1.s390
YOU Patch Nr: 10877
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.18
  • mod_php4-servlet >= 4.3.10-14.18
  • php4 >= 4.3.10-14.18
  • php4-32bit >= 9.3-7.8
  • php4-devel >= 4.3.10-14.18
  • php4-exif >= 4.3.10-14.18
  • php4-fastcgi >= 4.3.10-14.18
  • php4-mbstring >= 4.3.10-14.18
  • php4-pear >= 4.3.10-14.18
  • php4-session >= 4.3.10-14.18
  • php4-sysvshm >= 4.3.10-14.18