Upstream information

CVE-2005-3391 at MITRE

Description

Multiple vulnerabilities in PHP before 4.4.1 allow remote attackers to bypass safe_mode and open_basedir restrictions via unknown attack vectors in (1) ext/curl and (2) ext/gd.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 131580, 135673 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.46.8
  • apache2-mod_php4 >= 4.3.4-43.46.8
  • mod_php4-core >= 4.3.4-43.46.8
  • mod_php4-servlet >= 4.3.4-43.46.8
  • php4 >= 4.3.4-43.46.8
  • php4-devel >= 4.3.4-43.46.8
  • php4-exif >= 4.3.4-43.46.8
  • php4-fastcgi >= 4.3.4-43.46.8
  • php4-imap >= 4.3.4-43.46.8
  • php4-mbstring >= 4.3.4-43.46.8
  • php4-mysql >= 4.3.4-43.46.8
  • php4-pear >= 4.3.4-43.46.8
  • php4-recode >= 4.3.4-43.46.8
  • php4-servlet >= 4.3.4-43.46.8
  • php4-session >= 4.3.4-43.46.8
  • php4-sysvshm >= 4.3.4-43.46.8
suse91.s390
sles9-nlpos.x86
suse91.ppc
suse91.x86-64
YOU Patch Nr: 10794
SUSE LINUX 10.0
  • apache2-mod_php4 >= 4.4.0-6.6
  • php4 >= 4.4.0-6.6
  • php4-32bit >= 4.4.0-6.6
  • php4-64bit >= 4.4.0-6.6
  • php4-exif >= 4.4.0-6.6
  • php4-fastcgi >= 4.4.0-6.6
  • php4-mbstring >= 4.4.0-6.6
  • php4-servlet >= 4.4.0-6.6
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-498
  • mod_php4-core >= 4.2.2-498
  • mod_php4-devel >= 4.2.2-498
  • mod_php4-servlet >= 4.2.2-498
ul1.ppc
ul1.x86-64
ul1.ia64
slox4,2.x86
ul1.s390
YOU Patch Nr: 10803
SUSE LINUX 10.0
  • apache2-mod_php5 >= 5.0.4-9.6
  • php5 >= 5.0.4-9.6
  • php5-exif >= 5.0.4-9.6
  • php5-fastcgi >= 5.0.4-9.6
  • php5-mbstring >= 5.0.4-9.6
  • php5-pear >= 5.0.4-9.6
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • php5-suhosin >= 5.1.2-29.35
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2875
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.16
  • mod_php4-servlet >= 4.3.10-14.16
  • php4 >= 4.3.10-14.16
  • php4-32bit >= 9.3-7.7
  • php4-devel >= 4.3.10-14.16
  • php4-exif >= 4.3.10-14.16
  • php4-fastcgi >= 4.3.10-14.16
  • php4-mbstring >= 4.3.10-14.16
  • php4-pear >= 4.3.10-14.16
  • php4-session >= 4.3.10-14.16
  • php4-sysvshm >= 4.3.10-14.16
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.16
  • php5 >= 5.0.3-14.16
  • php5-devel >= 5.0.3-14.16
  • php5-exif >= 5.0.3-14.16
  • php5-fastcgi >= 5.0.3-14.16
  • php5-mbstring >= 5.0.3-14.16
  • php5-pear >= 5.0.3-14.16
  • php5-sysvmsg >= 5.0.3-14.16
  • php5-sysvshm >= 5.0.3-14.16