Upstream information

CVE-2005-3357 at MITRE

Description

mod_ssl in Apache 2.0 up to 2.0.55, when configured with an SSL vhost with access control and a custom error 400 error page, allows remote attackers to cause a denial of service (application crash) via a non-SSL request to an SSL port, which triggers a NULL pointer dereference.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.4
Vector AV:N/AC:H/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entries: 138083 [RESOLVED / FIXED], 186167 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • apache2 >= 2.0.49-27.45
  • apache2-devel >= 2.0.49-27.45
  • apache2-prefork >= 2.0.49-27.45
  • apache2-worker >= 2.0.49-27.45
  • libapr0 >= 2.0.49-27.45
SUSE LINUX 9.2
  • apache2 >= 2.0.50-7.12
  • apache2-devel >= 2.0.50-7.12
  • apache2-prefork >= 2.0.50-7.12
  • apache2-worker >= 2.0.50-7.12
  • libapr0 >= 2.0.50-7.12
SUSE LINUX 9.3
  • apache2 >= 2.0.53-9.10
  • apache2-devel >= 2.0.53-9.10
  • apache2-prefork >= 2.0.53-9.10
  • apache2-worker >= 2.0.53-9.10
  • libapr0 >= 2.0.53-9.10
Open Enterprise Server
  • apache2 >= 2.0.49-27.45
  • apache2-prefork >= 2.0.49-27.45
  • apache2-worker >= 2.0.49-27.45
core9.x86-64
core9.s390
core9.ppc
core9.ia64
core9.x86
YOU Patch Nr: 10850
Open Enterprise Server
  • apache2 >= 2.0.49-27.59
  • apache2-prefork >= 2.0.49-27.59
  • apache2-worker >= 2.0.49-27.59
sles9-nlpos.x86
core9.s390
YOU Patch Nr: 11203
SUSE LINUX 10.0
  • apache2 >= 2.0.54-10.8
  • apache2-prefork >= 2.0.54-10.8
  • apache2-worker >= 2.0.54-10.8
SUSE LINUX 9.2
  • apache2 >= 2.0.50-7.17
  • apache2-prefork >= 2.0.50-7.17
  • apache2-worker >= 2.0.50-7.17
SUSE LINUX 9.3
  • apache2 >= 2.0.53-9.15
  • apache2-prefork >= 2.0.53-9.15
  • apache2-worker >= 2.0.53-9.15
SUSE LINUX 10.0
  • apache2 >= 2.0.54-10.3
  • apache2-prefork >= 2.0.54-10.3
  • apache2-worker >= 2.0.54-10.3