Upstream information

CVE-2005-2960 at MITRE

Description

cfengine 1.6.5 and 2.1.16 allows local users to overwrite arbitrary files via a symlink attack on temporary files used by vicf.in, a different vulnerability than CVE-2005-3137.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 120075 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • cfengine >= 2.1.15-2.2
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • cfengine >= 2.0.7p3-146
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • cfengine >= 2.1.3-32.4
SUSE LINUX 9.2
  • cfengine >= 2.1.9-2.2
SUSE LINUX 9.3
  • cfengine >= 2.1.13-4.2