Upstream information

CVE-2005-2700 at MITRE

Description

ssl_engine_kernel.c in mod_ssl before 2.8.24, when using "SSLVerifyClient optional" in the global virtual host configuration, does not properly enforce "SSLVerifyClient require" in a per-location context, which allows remote attackers to bypass intended access restrictions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 114701, 118234, 118269, 186167 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Open Enterprise Server
  • apache2 >= 2.0.49-27.59
  • apache2-prefork >= 2.0.49-27.59
  • apache2-worker >= 2.0.49-27.59
sles9-nlpos.x86
core9.s390
YOU Patch Nr: 11203
SUSE LINUX 10.0
  • apache2 >= 2.0.54-10.8
  • apache2-prefork >= 2.0.54-10.8
  • apache2-worker >= 2.0.54-10.8
SUSE LINUX 9.2
  • apache2 >= 2.0.50-7.17
  • apache2-prefork >= 2.0.50-7.17
  • apache2-worker >= 2.0.50-7.17
SUSE LINUX 9.3
  • apache2 >= 2.0.53-9.15
  • apache2-prefork >= 2.0.53-9.15
  • apache2-worker >= 2.0.53-9.15
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • apache2 >= 2.0.49-27.34
  • apache2-devel >= 2.0.49-27.34
  • apache2-prefork >= 2.0.49-27.34
  • apache2-worker >= 2.0.49-27.34
  • libapr0 >= 2.0.49-27.34
SUSE LINUX 9.2
  • apache2 >= 2.0.50-7.7
  • apache2-devel >= 2.0.50-7.7
  • apache2-prefork >= 2.0.50-7.7
  • apache2-worker >= 2.0.50-7.7
  • libapr0 >= 2.0.50-7.7
SUSE LINUX 9.3
  • apache2 >= 2.0.53-9.5
  • apache2-devel >= 2.0.53-9.5
  • apache2-prefork >= 2.0.53-9.5
  • apache2-worker >= 2.0.53-9.5
  • libapr0 >= 2.0.53-9.5
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • libapr0 >= 2.0.49-27.34
sles9-nlpos.x86
suse91.x86-64
suse91.ppc
suse91.s390
suse91.ia64
YOU Patch Nr: 10476
Open Enterprise Server
  • apache2 >= 2.0.49-27.34
  • apache2-devel >= 2.0.49-27.34
  • apache2-prefork >= 2.0.49-27.34
  • apache2-worker >= 2.0.49-27.34
  • libapr0 >= 2.0.49-27.34
sles9-nlpos.x86
suse91.x86-64
suse91.ppc
suse91.s390
suse91.ia64
YOU Patch Nr: 10476