Upstream information

CVE-2005-1852 at MITRE

Description

Multiple integer overflows in libgadu, as used in Kopete in KDE 3.2.3 to 3.4.1, ekg before 1.6rc3, GNU Gadu, CenterICQ, Kadu, and other packages, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an incoming message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 102961 [RESOLVED], 97408 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • kdenetwork3-nld-InstantMessenger >= 3.3.0-0.12
Builds
YOU Patch Nr: 10477
SUSE LINUX 9.3
  • kdenetwork3 >= 3.4.0-16.4
  • kdenetwork3-InstantMessenger >= 3.4.0-16.4
SuSE Linux Desktop 1.0
  • gaim >= 0.59-184
Builds
YOU Patch Nr: 10405
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • gaim >= 1.2.0-0.7
Builds
YOU Patch Nr: 10405