Upstream information

CVE-2005-1349 at MITRE

Description

Buffer overflow in Convert-UUlib (Convert::UUlib) before 1.051 allows remote attackers to execute arbitrary code via a malformed parameter to a read operation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 81068 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • amavisd-new >= 2.6.2-1.14
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA amavisd-new
SUSE Linux Enterprise Server 11 SP2
  • amavisd-new >= 2.7.0-18.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA amavisd-new
SUSE Linux Enterprise Server 11 SP3
  • amavisd-new >= 2.7.0-18.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA amavisd-new
SUSE Linux Enterprise Server 11 SP4
  • amavisd-new >= 2.7.0-18.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA amavisd-new
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
  • perl-Convert-UUlib >= 0.213-139
suse91.ppc
suse91.x86
slss8.x86
suse91.s390x
suse91.x86-64
suse91.ia64
suse91.s390
YOU Patch Nr: 10044
Open Enterprise Server
  • perl-Convert-UUlib >= 1.0-25.4
suse91.ppc
suse91.x86
slss8.x86
suse91.s390x
suse91.x86-64
suse91.ia64
suse91.s390
YOU Patch Nr: 10044
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
  • perl-Convert-UUlib >= 0.213-142
slss8.x86
YOU Patch Nr: 10240
SuSE Linux 8.2 for IA32
  • perl-Convert-UUlib >= 0.213-140
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • perl-Convert-UUlib >= 0.31-106
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • perl-Convert-UUlib >= 1.0-25.4
SUSE LINUX 9.2
  • perl-Convert-UUlib >= 1.0-27.2
SUSE LINUX 9.3
  • perl-Convert-UUlib >= 1.0-28.2