Upstream information

CVE-2005-0005 at MITRE

Description

Heap-based buffer overflow in psd.c for ImageMagick 6.1.0, 6.1.7, and possibly earlier versions allows remote attackers to execute arbitrary code via a .PSD image file with a large number of layers.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 64839, 65351 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
  • ImageMagick >= 5.5.7-225.12
  • ImageMagick-devel >= 5.5.7-225.12
core9.x86-64
core9.ia64
core9.ppc
core9.s390
core9.s390x
core9.x86
core9.x86-64
YOU Patch Nr: 9795
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • ImageMagick >= 5.5.7-225.12
  • ImageMagick-Magick++ >= 5.5.7-225.12
  • ImageMagick-devel >= 5.5.7-225.12
  • perl-PerlMagick >= 5.5.7-225.12
core9.x86-64
core9.ia64
core9.ppc
core9.s390
core9.s390x
core9.x86
core9.x86-64
YOU Patch Nr: 9795
SuSE Linux Desktop 1.0
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
  • ImageMagick >= 5.4.7-277
slss8.x86
YOU Patch Nr: 9794
SUSE Linux Enterprise Desktop 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP1 for x86
  • perl-PerlMagick >= 6.2.5-16.20
ZYPP Patch Nr: 2933