Upstream information

CVE-2004-0688 at MITRE

Description

Multiple integer overflows in (1) the xpmParseColors function in parse.c, (2) XpmCreateImageFromXpmImage, (3) CreateXImage, (4) ParsePixels, and (5) ParseAndPutPixels for libXpm before 6.8.1 may allow remote attackers to execute arbitrary code via a malformed XPM image file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 58240, 84749

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • openmotif >= 2.2.2-522
  • openmotif-devel >= 2.2.2-522
core9.ia64
suse91.x86
core9.x86-64
slox4,2.x86
core9.ppc
core9.s390
core9.s390x
YOU Patch Nr: 9402
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • xshared >= 4.2.0-269
ul1.x86-64
ul1.ppc
slox4,2.x86
ul1.s390
ul1.ia64
YOU Patch Nr: 9474
SuSE Linux Desktop 1.0
  • XFree86-libs >= 4.3.0-132
suse91.s390x
suse91.x86
suse91.x86-64
suse91.s390
suse91.ppc
suse91.ia64
YOU Patch Nr: 9475
Novell Linux Desktop 9 for x86
  • XFree86-libs >= 4.3.99.902-43.35.3
suse91.s390x
suse91.x86
suse91.x86-64
suse91.s390
suse91.ppc
suse91.ia64
YOU Patch Nr: 9475
SUSE Linux Enterprise Desktop 10 SP1 for x86
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • xorg-x11-devel >= 6.9.0-50.45
sled10.x86
sles10.s390x
ZYPP Patch Nr: 2924
SUSE Linux Enterprise Desktop 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
  • xorg-x11-devel >= 6.9.0-50.45
  • xorg-x11-devel-32bit >= 6.9.0-50.45
sled10.x86
sles10.s390x
ZYPP Patch Nr: 2924
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
  • xorg-x11-devel >= 6.9.0-50.45
  • xorg-x11-devel-64bit >= 6.9.0-50.45
sled10.x86
sles10.s390x
ZYPP Patch Nr: 2924
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • xshared >= 4.2.0-267
ul1.s390
ul1.ppc
ul1.s390x
ul1.ia64
slox4,2.x86
ul1.x86-64
YOU Patch Nr: 9362
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • openmotif21-libs >= 2.1.30MLI4-122
suse91.x86
suse91.s390
slox4,2.x86
suse91.ia64
suse91.ppc
ul1.ia64
YOU Patch Nr: 9399
SuSE Linux Desktop 1.0
  • XFree86-libs >= 4.3.0-128
suse91.x86-64
suse91.s390
suse91.s390x
suse91.x86
suse91.ia64
suse91.ppc
YOU Patch Nr: 9367
SuSE Linux Desktop 1.0
  • openmotif >= 2.2.2-522
Builds
SuSE Linux 8.1 for IA32
  • openmotif >= 2.2.2-522
  • openmotif-demo >= 2.2.2-522
  • openmotif-devel >= 2.2.2-522
SuSE Linux 8.2 for IA32
  • openmotif >= 2.2.2-524
  • openmotif-demo >= 2.2.2-524
  • openmotif-devel >= 2.2.2-524
SuSE Linux 9.0 for IA32
  • openmotif >= 2.2.2-523
  • openmotif-demo >= 2.2.2-523
  • openmotif-devel >= 2.2.2-523
SuSE Linux 9.0 for AMD64
  • openmotif >= 2.2.2-523
  • openmotif-demo >= 2.2.2-523
  • openmotif-devel >= 2.2.2-523
  • openmotif-devel-32bit >= 9.0-4
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • openmotif >= 2.2.2-519.4
  • openmotif-demo >= 2.2.2-519.4
  • openmotif-devel >= 2.2.2-519.4