Upstream information

CVE-2018-12020 at MITRE

Description

mainproc.c in GnuPG before 2.2.8 mishandles the original filename during decryption and verification actions, which allows remote attackers to spoof the output that GnuPG sends on file descriptor 2 to other programs that use the "--status-fd 2" option. For example, the OpenPGP data might represent an original filename that contains line feed characters in conjunction with GOODSIG or VALIDSIG status codes.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None Low
Integrity Impact High Low
Availability Impact None Low

Note from the SUSE Security Team

This issue affects the GnuPG CLI in non-default configurations. While zypper/libzypp use GnuPG for repository signature verification, they are not affected: In SLE 12 and earlier, verbose output is not configured or requested via the command line. In SLE 15, libzypp uses gpgme as an interface to GnuPG.

SUSE Bugzilla entries: 1096745 [RESOLVED / FIXED], 1101134 [REOPENED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • gpg2 >= 2.0.24-9.3.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-1141
SUSE CaaS Platform ALL
  • gpg2 >= 2.0.24-9.3.1
Patchnames:
SUSE-CAASP-ALL-2018-1141
SUSE Enterprise Storage 4
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-Storage-4-2018-1141
SUSE Linux Enterprise Desktop 12 SP3
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1141
SUSE Linux Enterprise Desktop 12 SP4
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA gpg2
SUSE Linux Enterprise Module for Basesystem 15
  • gpg2 >= 2.2.5-4.3.1
  • gpg2-lang >= 2.2.5-4.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1223
SUSE Linux Enterprise Point of Sale 11 SP3
  • gpg2 >= 2.0.9-25.33.42.3.1
  • gpg2-lang >= 2.0.9-25.33.42.3.1
Patchnames:
sleposp3-gpg2-13655
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1141
SUSE Linux Enterprise Server 11 SP3-LTSS
  • gpg2 >= 2.0.9-25.33.42.3.1
  • gpg2-lang >= 2.0.9-25.33.42.3.1
Patchnames:
slessp3-gpg2-13655
SUSE Linux Enterprise Server 11 SP4
  • gpg2 >= 2.0.9-25.33.42.3.1
  • gpg2-lang >= 2.0.9-25.33.42.3.1
Patchnames:
slessp4-gpg2-13655
SUSE Linux Enterprise Server 12 SP1-LTSS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1141
SUSE Linux Enterprise Server 12 SP2-BCL
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1141
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1141
SUSE Linux Enterprise Server 12 SP2-LTSS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1141
SUSE Linux Enterprise Server 12 SP3
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1141
SUSE Linux Enterprise Server 12 SP4
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA gpg2
SUSE Linux Enterprise Server 12-LTSS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1141
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • gpg2 >= 2.0.9-25.33.42.3.1
  • gpg2-lang >= 2.0.9-25.33.42.3.1
Patchnames:
slessp3-gpg2-13655
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • gpg2 >= 2.0.9-25.33.42.3.1
  • gpg2-lang >= 2.0.9-25.33.42.3.1
Patchnames:
slessp4-gpg2-13655
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-1141
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1141
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1141
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1141
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1141
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1141
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1141
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1141
SUSE Linux Enterprise Workstation Extension 15
  • enigmail >= 2.0.7-3.7.2
Patchnames:
SUSE-SLE-Product-WE-15-2018-1514
SUSE OpenStack Cloud 7
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1141
SUSE Package Hub for SUSE Linux Enterprise 12
  • enigmail >= 2.0.7-18.1
Patchnames:
openSUSE-2018-630
openSUSE Leap 15.0
  • enigmail >= 2.0.7-lp150.2.12.1
  • gpg2 >= 2.2.5-lp150.3.3.1
  • gpg2-debuginfo >= 2.2.5-lp150.3.3.1
  • gpg2-debugsource >= 2.2.5-lp150.3.3.1
  • gpg2-lang >= 2.2.5-lp150.3.3.1
  • python-python-gnupg >= 0.4.3-lp150.2.3.1
  • python2-python-gnupg >= 0.4.3-lp150.2.3.1
  • python3-python-gnupg >= 0.4.3-lp150.2.3.1
Patchnames:
openSUSE-2018-630
openSUSE-2018-640
openSUSE-2018-646
openSUSE Leap 42.3
  • enigmail >= 2.0.7-21.1
  • gpg2 >= 2.0.24-9.3.1
  • gpg2-debuginfo >= 2.0.24-9.3.1
  • gpg2-debugsource >= 2.0.24-9.3.1
  • gpg2-lang >= 2.0.24-9.3.1
Patchnames:
openSUSE-2018-630
openSUSE-2018-640


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 gpg2 Released
CaaS Platform 3.0 gpg2 Released
OpenStack Cloud Magnum Orchestration 7.0 gpg2 Released
SUSE Linux Enterprise Desktop 12 SP3 gpg2 Released
SUSE Linux Enterprise Module for Basesystem 15 GA gpg2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS gpg2 Released
SUSE Linux Enterprise Server 11 SP4 gpg2 Released
SUSE Linux Enterprise Server 12 GA LTSS gpg2 Released
SUSE Linux Enterprise Server 12 SP1 LTSS gpg2 Released
SUSE Linux Enterprise Server 12 SP2 LTSS gpg2 Released
SUSE Linux Enterprise Server 12 SP3 gpg2 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gpg2 Released
SUSE Linux Enterprise Workstation Extension 15 GA enigmail Released