Upstream information

CVE-2021-41239 at MITRE

Description

Nextcloud server is a self hosted system designed to provide cloud style services. In affected versions the User Status API did not consider the user enumeration settings by the administrator. This allowed a user to enumerate other users on the instance, even when user listings where disabled. It is recommended that the Nextcloud Server is upgraded to 20.0.14, 21.0.6 or 22.2.1. There are no known workarounds.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 4.3
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1196905 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 12
  • nextcloud >= 21.0.9-37.1
  • nextcloud-apache >= 21.0.9-37.1
Patchnames:
openSUSE-2022-89
SUSE Package Hub 15 SP3
  • nextcloud >= 21.0.9-bp153.2.12.1
  • nextcloud-apache >= 21.0.9-bp153.2.12.1
Patchnames:
openSUSE-2022-98
openSUSE Leap 15.3
  • nextcloud >= 21.0.9-bp153.2.12.1
  • nextcloud-apache >= 21.0.9-bp153.2.12.1
Patchnames:
openSUSE-2022-98


SUSE Timeline for this CVE

CVE page created: Tue Mar 8 23:00:08 2022
CVE page last modified: Wed Oct 26 23:26:37 2022