Upstream information

CVE-2015-1840 at MITRE


jquery_ujs.js in jquery-rails before 3.1.3 and 4.x before 4.0.4 and rails.js in jquery-ujs before 1.0.4, as used with Ruby on Rails 3.x and 4.x, allow remote attackers to bypass the Same Origin Policy, and trigger transmission of a CSRF token to a different-domain web server, via a leading space character in a URL within an attribute value.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1172184 [NEW], 934795 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ruby2.2-rubygem-jquery-rails >= 4.2.1-1.1
  • ruby2.2-rubygem-jquery-rails-doc >= 4.2.1-1.1
  • ruby2.2-rubygem-jquery-rails-testsuite >= 4.2.1-1.1
  • ruby2.3-rubygem-jquery-rails >= 4.2.1-1.1
  • ruby2.3-rubygem-jquery-rails-doc >= 4.2.1-1.1
  • ruby2.3-rubygem-jquery-rails-testsuite >= 4.2.1-1.1
  • ruby2.7-rubygem-jquery-rails >= 4.4.0-1.7
  • ruby3.0-rubygem-jquery-rails >= 4.4.0-1.7
  • ruby3.1-rubygem-jquery-rails >= 4.5.0-1.1
openSUSE Tumbleweed GA ruby2.2-rubygem-jquery-rails-4.2.1-1.1
openSUSE Tumbleweed GA ruby2.7-rubygem-jquery-rails-4.4.0-1.7
openSUSE Tumbleweed GA ruby3.1-rubygem-jquery-rails-4.5.0-1.1