Upstream information

CVE-2023-25565 at MITRE


GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, an incorrect free when decoding target information can trigger a denial of service. The error condition incorrectly assumes the `cb` and `sh` buffers contain a copy of the data that needs to be freed. However, that is not the case. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point. This will likely trigger an assertion failure in `free`, causing a denial-of-service. This issue is fixed in version 1.2.0.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1208280 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 8
  • gssntlmssp >= 1.2.0-1.el8_8
SUSE Package Hub 15 SP4
  • gssntlmssp >= 1.2.0-bp154.2.3.1
  • gssntlmssp-devel >= 1.2.0-bp154.2.3.1
openSUSE Leap 15.4
  • gssntlmssp >= 1.2.0-bp154.2.3.1
  • gssntlmssp-devel >= 1.2.0-bp154.2.3.1
openSUSE Tumbleweed
  • gssntlmssp >= 1.2.0-1.1
  • gssntlmssp-devel >= 1.2.0-1.1
openSUSE Tumbleweed GA gssntlmssp-1.2.0-1.1

SUSE Timeline for this CVE

CVE page created: Tue Feb 14 21:01:00 2023
CVE page last modified: Mon Oct 30 18:18:59 2023