Upstream information

CVE-2021-31924 at MITRE

Description

Yubico pam-u2f before 1.1.1 has a logic issue that, depending on the pam-u2f configuration and the application used, could lead to a local PIN bypass. This issue does not allow user presence (touch) or cryptographic signature verification to be bypassed, so an attacker would still need to physically possess and interact with the YubiKey or another enrolled authenticator. If pam-u2f is configured to require PIN authentication, and the application using pam-u2f allows the user to submit NULL as the PIN, pam-u2f will attempt to perform a FIDO2 authentication without PIN. If this authentication is successful, the PIN requirement is bypassed.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.8 7.3
Vector CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Physical Local
Access Complexity Low Low
Privileges Required None Low
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186577 [RESOLVED / UPSTREAM]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 pam_u2f Not affected
SUSE Enterprise Storage 6 pam_u2f Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 pam_u2f Not affected
SUSE Linux Enterprise High Performance Computing 15 LTSS pam_u2f Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS pam_u2f Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 pam_u2f Not affected
SUSE Linux Enterprise Server 12 SP4 ESPOS pam_u2f Not affected
SUSE Linux Enterprise Server 12 SP4 LTSS pam_u2f Not affected
SUSE Linux Enterprise Server 12 SP5 pam_u2f Not affected
SUSE Linux Enterprise Server 15 LTSS pam_u2f Not affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux pam_u2f Not affected
SUSE Linux Enterprise Server 15 SP1 LTSS pam_u2f Not affected
SUSE Linux Enterprise Server ESPOS 15 pam_u2f Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 pam_u2f Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 pam_u2f Not affected
SUSE Linux Enterprise Server for SAP Applications 15 pam_u2f Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 pam_u2f Not affected
SUSE Manager Proxy 4.0 pam_u2f Not affected
SUSE Manager Retail Branch Server 4.0 pam_u2f Not affected
SUSE Manager Server 4.0 pam_u2f Not affected
SUSE OpenStack Cloud 9 pam_u2f Not affected
SUSE OpenStack Cloud Crowbar 9 pam_u2f Not affected