Upstream information

CVE-2021-29472 at MITRE


Composer is a dependency manager for PHP. URLs for Mercurial repositories in the root composer.json and package source download URLs are not sanitized correctly. Specifically crafted URL values allow code to be executed in the HgDriver if hg/Mercurial is installed on the system. The impact to Composer users directly is limited as the composer.json file is typically under their own control and source download URLs can only be supplied by third party Composer repositories they explicitly trust to download and execute source code from, e.g. Composer plugins. The main impact is to services passing user input to Composer, including and Private Packagist. This allowed users to trigger remote code execution. The vulnerability has been patched on and Private Packagist within 12h of receiving the initial vulnerability report and based on a review of logs, to the best of our knowledge, was not abused by anyone. Other services/tools using VcsRepository/VcsDriver or derivatives may also be vulnerable and should upgrade their composer/composer dependency immediately. Versions 1.10.22 and 2.0.13 include patches for this issue.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1185376 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP1
  • php-composer >= 1.10.22-bp151.3.3.1
SUSE Package Hub 15 SP2
  • php-composer >= 1.10.22-bp152.2.3.1
SUSE Package Hub 15 SP3
  • php-composer >= 1.10.22-bp153.2.3.1
openSUSE Leap 15.2
  • php-composer >= 1.10.22-lp152.2.3.1
openSUSE Leap 15.3
  • php-composer >= 1.10.22-bp153.2.3.1
openSUSE Tumbleweed
  • php-composer >= 1.10.22-2.2
openSUSE Tumbleweed GA php-composer-1.10.22-2.2

SUSE Timeline for this CVE

CVE page created: Wed Apr 28 08:45:56 2021
CVE page last modified: Tue May 23 18:05:33 2023