Upstream information

CVE-2021-20314 at MITRE

Description

Stack buffer overflow in libspf2 versions below 1.2.11 when processing certain SPF macros can lead to Denial of service and potentially code execution via malicious crafted SPF explanation messages.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1189104 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub 15 SP1
  • libspf2-2 >= 1.2.10-bp151.7.1
  • libspf2-devel >= 1.2.10-bp151.7.1
  • libspf2-tools >= 1.2.10-bp151.7.1
Patchnames:
openSUSE-2021-1187
SUSE Package Hub 15 SP2
  • libspf2-2 >= 1.2.10-bp152.8.1
  • libspf2-devel >= 1.2.10-bp152.8.1
  • libspf2-tools >= 1.2.10-bp152.8.1
Patchnames:
openSUSE-2021-1187
SUSE Package Hub 15 SP3
  • libspf2-2 >= 1.2.10-bp153.5.1
  • libspf2-devel >= 1.2.10-bp153.5.1
  • libspf2-tools >= 1.2.10-bp153.5.1
Patchnames:
openSUSE-2021-1187
openSUSE Leap 15.2
  • libspf2-2 >= 1.2.10-lp152.4.3.1
  • libspf2-devel >= 1.2.10-lp152.4.3.1
  • libspf2-tools >= 1.2.10-lp152.4.3.1
Patchnames:
openSUSE-2021-1187
openSUSE Leap 15.3
  • libspf2-2 >= 1.2.10-bp153.5.1
  • libspf2-devel >= 1.2.10-bp153.5.1
  • libspf2-tools >= 1.2.10-bp153.5.1
Patchnames:
openSUSE-2021-1187
openSUSE Tumbleweed
  • libspf2-2 >= 1.2.10-5.3
  • libspf2-apidocs >= 1.2.10-5.3
  • libspf2-devel >= 1.2.10-5.3
  • libspf2-tools >= 1.2.10-5.3
  • perl-Mail-SPF_XS >= 0.01-5.3
Patchnames:
openSUSE Tumbleweed GA libspf2-2-1.2.10-5.3