Upstream information

CVE-2021-20217 at MITRE

Description

A flaw was found in Privoxy in versions before 3.0.31. An assertion failure triggered by a crafted CGI request may lead to denial of service. The highest threat from this vulnerability is to system availability.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1181650 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 15 SP2
  • privoxy >= 3.0.31-bp152.4.6.1
  • privoxy-doc >= 3.0.31-bp152.4.6.1
Patchnames:
openSUSE-2021-279
openSUSE Leap 15.2
  • privoxy >= 3.0.31-lp152.3.6.1
  • privoxy-doc >= 3.0.31-lp152.3.6.1
Patchnames:
openSUSE-2021-265
openSUSE Tumbleweed
  • privoxy >= 3.0.32-2.3
  • privoxy-doc >= 3.0.32-2.3
Patchnames:
openSUSE Tumbleweed GA privoxy-3.0.32-2.3