Upstream information

CVE-2020-15202 at MITRE

Description

In Tensorflow before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, the `Shard` API in TensorFlow expects the last argument to be a function taking two `int64` (i.e., `long long`) arguments. However, there are several places in TensorFlow where a lambda taking `int` or `int32` arguments is being used. In these cases, if the amount of work to be parallelized is large enough, integer truncation occurs. Depending on how the two arguments of the lambda are used, this can result in segfaults, read/write outside of heap allocated arrays, stack overflows, or data corruption. The issue is patched in commits 27b417360cbd671ef55915e4bb6bb06af8b8a832 and ca8c013b5e97b1373b3bb1c97ea655e69f31a575, and is released in TensorFlow versions 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
No SUSE Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.2
  • libtensorflow2 >= 2.1.2-lp152.7.3.1
  • libtensorflow2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_cc2 >= 2.1.2-lp152.7.3.1
  • libtensorflow_cc2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_cc2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_framework2 >= 2.1.2-lp152.7.3.1
  • libtensorflow_framework2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • libtensorflow_framework2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2 >= 2.1.2-lp152.7.3.1
  • tensorflow2-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2-doc >= 2.1.2-lp152.7.3.1
  • tensorflow2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2-lite >= 2.1.2-lp152.7.3.1
  • tensorflow2-lite-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-hpc-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-hpc-doc >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-openmpi2-hpc >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-openmpi2-hpc-devel >= 2.1.2-lp152.7.3.1
  • tensorflow2_2_1_2-gnu-openmpi2-hpc-doc >= 2.1.2-lp152.7.3.1
Patchnames:
openSUSE-2020-1766