Upstream information

CVE-2018-10847 at MITRE

Description

prosody before versions 0.10.2, 0.9.14 is vulnerable to an Authentication Bypass. Prosody did not verify that the virtual host associated with a user session remained the same across stream restarts. A user may authenticate to XMPP host A and migrate their authenticated session to XMPP host B of the same Prosody instance.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1094890 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • prosody >= 0.10.2-lp150.3.6.2
  • prosody-debuginfo >= 0.10.2-lp150.3.6.2
  • prosody-debugsource >= 0.10.2-lp150.3.6.2
Patchnames:
openSUSE-2018-596
openSUSE Leap 42.3
  • prosody >= 0.9.13-2.6.1
  • prosody-debuginfo >= 0.9.13-2.6.1
  • prosody-debugsource >= 0.9.13-2.6.1
Patchnames:
openSUSE-2018-597